Configuration SAML login using AzureAD

Hi, I want integrated the login nextcloud with me AzureAd I have followed the manual step by step, after several attempts and review of permissions on the tenant I still get the following failure:

AADSTS700016: Application with identifier ‘’ was not found in the directory ‘namedtenant’. This can happen if the application has not been installed by the administrator of the tenant or consented to by any user in the tenant. You may have sent your authentication request to the wrong tenant.

I have a feeling it’s something on the azure side, I have followed these steps which are not official…

Thanks colleagues!

I don’t know for sure but I would bet AAD doesn’t allow plain http:// for SAML (maybe it’s not even allowed by SAML protocol)…

from the error message it sounds like you didn’t create the AAD application (in a right way). Maybe there is a typo or you choose another ID or options… maybe you didn’t provide “consent” for the application. I didn’t test but from my experience the guide sounds reasonable… I would review every single step and verify you match both sides exactly (e.g. http:// vs https://)

I deleted your identical post in old thread Office 365, Azure AD SSO? - please don’t hijack old topics!


I have the same issue. Haven’t found any solution yet.

Hola la solucion fue subir al portal de Azure

Hi Brian,

Sorry but I don’t understand really. Do you mean that I should upload the metadata XML from Nextcloud to Azure? If yes, where?