Conection refused from local IP

I setup a home server on Ubuntu 20.04, latest nextcloud 22.0.0, standard installation (not docker), php 8.0.8, MariaDB, Apache

Everything was working normal inside my LAN, then i tried to setup DAVx on my phone but instead of using the nextcloud webdav url i used the main domain… the login did not work and now the server does not let me connect anymore. i get the connection refused message from my computer inside the lan.,

things i already tried:

  1. check nextcloud log… nothing useful
  2. add the local LAN ip address to the whitelist section under security… no go
  3. disable the brute force add on and restart server once the database is clear of blocked IP addresses … nada
  4. restart the server … still no access.
  5. Login to MariaDB nextcloud database and execute `DELETE FROM oc_bruteforce_attempts WHERE ip = ‘192.168.88.1’;
  6. edited /var/www/nextcloud/config/config.php and set the bruteforce protection to False… no luck
    `

If i use a VPN, so i get a different IP, the server lets me connect immediately.

Please let me know of any tricks to clear the banning within my local network.
Thank you
Screenshots:

My first guess would be that you forgot to enlist the local Ip in your config.php file or made a misstipe and the config filewasn’t read exactly. Could you pls poste your config.php?

Could you elaborate or show a guide on this? No i did not have to edit the config.php file and i am looking at it and there is no such entry to “whitelist” any ip addres, but rather the information so nextcloud can login on every needed service.

To give an update…
today i was able to login as 24HS have passed… But this seems to be a BUG with that bruteforce plugin, it does not work even whitelisting the IPs.
I have posted several places where these options reside but seems like no one else knows where the ban list of the ips is located.

I believe that was meant Trusted Domain setting https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/config_sample_php_parameters.html#default-parameters but this is not causing this problem.
Please go to your browser debug settings - Network and check what IP you tries to reach when you call your server. I have strong believe that if you are calling your https://DOMAIN from the LAN your router simply could not forward this back to your server or port is closed. Check this out → Unable to access NextCloud on local lan - #4 by gas85

Thank you for the suggestions.
Trusted domain is the domain i am using for this instance…
I have full access now after the 24 hours lock has expired. There is no problem with my router, i am accessing the instance inside my LAN using the cloud.mydomain.com address on SSL.
It is a glitch with that bruteforce plugin. I did not change anything else

1 Like

just ad the local ip as trusted domain and it should work.