Composer requires PHP version >= 7.4.0?

I’ve done something to break my NCP instance. Tried to log into the web interface this morning and got this message: Composer detected issues in your platform: Your Composer dependencies require a PHP version “>= 7.4.0”

Any thoughts on what night be causing this? Can I update to PHP 7.4? Can I remove something that might be asking for PHP 7.4?

Thanks!

What did you do exactly?
What Composer?

Php7.4 will be supported by ncp when it moves to Debian 11 Bullseye.
What does your nc-info look like?

I don’t know what I did, that’s mostly the problem. Don’t know that composer is either. That’s new to me.

NextCloudPi version	v1.44.5
NextCloudPi image	NextCloudPi_11-27-20
OS	Armbian 21.08.6 Buster \l . 4.4.213-rockchip64 (aarch64)
automount	no
USB devices	none
datadir	/media/ncpstorage/ncdata
data in SD	no
data filesystem	ext2/ext3
data disk usage	13G/7.3T
rootfs usage	2.2G/57G
swapfile	/media/ncpstorage/swap
dbdir	/media/ncpstorage/ncdatabase
Nextcloud check	ok
Nextcloud version	22.2.2.0
HTTPD service	up
PHP service	up
MariaDB service	up
Redis service	up
HPB service	up
Postfix service	up
internet check	ok
port check 80	open
port check 443	open
IP	192.168.10.3
gateway	192.168.10.1
interface	eth0
certificates	nextcloud.XXXXXXXX.com
NAT loopback	yes
uptime	42min


passwordsalt	
secret	
trusted_domains	
0	localhost
5	nextcloudpi.local
7	nextcloudpi
8	nextcloudpi.lan
1	192.168.10.3
12	nextcloud.XXXXXX.com
3	nextcloud.XXXXXXXX.com
22	nextcloudpi
14	nextcloudpi
nextcloud.XXXXXXX.com
datadirectory	/media/ncpstorage/ncdata
dbtype	mysql
version	22.2.2.0
overwrite.cli.url	https://nextcloud.XXXXXX.com/
dbname	nextcloud
dbhost	localhost
dbport	
dbtableprefix	oc_
mysql.utf8mb4	1
dbuser	
dbpassword	
default_phone_region	EN
installed	1
instanceid XXXXXXX
memcache.local	\OC\Memcache\Redis
memcache.locking	\OC\Memcache\Redis
redis	
host	/var/run/redis/redis.sock
port	0
timeout	0
password	
tempdirectory	/media/ncpstorage/ncdata/tmp
mail_smtpmode	smtp
mail_smtpauthtype	LOGIN
mail_from_address	XXXX
mail_domain XXXXXXXXX.com
preview_max_x	2048
preview_max_y	2048
jpeg_quality	60
overwriteprotocol	https
maintenance	
logfile	/media/ncpstorage/ncdata/nextcloud.log
mail_sendmailmode	smtp
mail_smtpauth	1
mail_smtphost	smtp.XXXXXXXX.com
mail_smtpport	465
mail_smtpsecure	ssl
mail_smtpname	XXXXXX@XXXXXXXX.com
mail_smtppassword	
loglevel	2
log_type	file
trusted_proxies	
11	127.0.0.1
12	::1
13	nextcloud.XXXXXX.com
14	192.168.10.3

Just to fill in some context :slight_smile:

Composer is a Dependency Manager for PHP

https://getcomposer.org/

Here is another topic about Composer, it primarily seems to be used as a third-party apps dependency manager

1 Like

sounds like an app that was auto-updated and didn’t check for the php dependency

Interesting. Sounds reasonable. I’ll have to check, I don’t think I have app auto-update on.

Nowt o figure out the offending app and disable it. Ideas on how to do that from the command line?

do sudo ncc list and you should see a list of available commands you can use :slightly_smiling_face:

1 Like

Thank you @ZendaiOwl , that helped! I was able to disable TwoFactor WebAuthn and then login to my instance.

Developed fixed the issue in a later version and I was able to upgrade to that fixed version.

Appreciate the assistance!

1 Like

fyi, the ncc command features bash tab-completion, so you can ncc <tab> and get info that way too :wink:

1 Like