Commandline Updater does not show any available updates

Here’s my problem,
When I open Overview in Administrative Settings it shows NC26 Update is available.

If I click on Open Updater it just simply redirects me to Home screen.

I already tried editing .step file but nothing works.

Then I tried commandline upgrader but when i tried commandline upgrader it doesn’t show any available updates.

I even tried replacing updater.phar with latest one but still no luck

Can anyone helps me with it?


Afaik, the web update is a separate tool. When you want to use the command line OCC, you have to change the files in the directory first (download from website/github > remove old files (without data and config dir), paste new files in folder). Then you can run the occ upgrade command (like you’d do it when you access the instance again, you’d see a button to update (with the hint to use the command line on bigger instances)).

Hey Phil, thanks for quick response,
what i understand is to download the latest zip file and upload the files into root directory except data and config dir, am i right?


sudo -u www-data php -f /var/www/nextcloud/occ upgrade

is something completely different to

sudo -u www-data /usr/bin/php -d memory_limit=512M -f /var/www/nextcloud/updater/updater.phar

which in fact does all the steps you described but by script and safe.
If the updater.phar tool is successful, then it will result in the occ upgrade, but all by itself, it just needs to be confirmed.

Try to temporarily switch your update channel to beta, then update (with updater.phar like above) and then switch back to stable.