Command "db:add-missing-primary-keys" is not defined after upgrade to 20.0.2 RC1

I upgraded my beta testinstance to 20.0.2 RC1. The upgrade itself went fine. Thereafter, in the Overview page, it displayed the message

The database is missing some primary keys. Due to the fact that adding primary keys on big tables could take some time they were not added automatically. By running “occ db:add-missing-primary-keys” those missing primary keys could be added manually while the instance keeps running.

When I run the suggested command, I get:

Command "db:add-missing-primary-keys" is not defined.                                                                                                                                                        
  Did you mean one of these?                                                                                                                                                                                   

Is there something wrong with the occ command?

It seems that they’ve just forgotten to register the new command correctly. Check-out the following issue report which refers to a pull request which fixes the problem:

That worked, thank you!

How does this work on a hosted site (ionos): I only have access to phpmyadmin. What are the commands to change it there?

That depends on your hoster: Please file a ticket and ask for a solution.

Some offer to execute commands via WebGUI, some offer shell access with limited functions.

Thanks. I just solved it with this command in PHPMyadmin:

alter table TABLE_NAME add column `id` int(10) unsigned primary AUTO_INCREMENT;
1 Like

Haven’t mentioned that, sorry.
Sometimes it has bad results to recommend people executing SQL statements :wink:

Well done!