Collabora without Docker, connection refused

Nextcloud version (eg, 18.0.2): 20.0.5
Operating system and version (eg, Ubuntu 20.04): Debian 10
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.38
PHP version (eg, 7.1): 7.3

Yesterday I tried to set up Collabora server with multiple approaches, failing them all and made a very messy post about it. Today I dropped the builtin server as well as the docker thing, and tried to install the standalone server and set up reverse proxy for it. It went slightly better, as now Nextcloud finds the server:

Anyway, I still can’t access files. When I try to open a file, I see this:

So basically what I have done:

  • I followed this guide to install Collabora Server Integrate Collabora Online with Nextcloud on Ubuntu without Docker
  • But as my ISP blocks all usual ports including 80 and 443, I can’t set encryption with letsencrypt
  • That’s why I have my domain on namecheap and I have bought PositiveSSL for both my nextcloud domain ( and my collabora domain (
  • I have routed HTTP traffic to port 1025 instead of 80 and HTTPS traffic to port 6800 instead of 443
  • So instead of setting letsencrypt I added the SSL lines to my /etc/apache2/sites-enabled/collabora.conf, does this look correct?
<VirtualHost *:6800>
  Options -Indexes
  # SSL domain
  SSLEngine on
  SSLCertificateFile /etc/ssl/office/office_jukranpujut_net.crt
  SSLCertificateChainFile /etc/ssl/office/
  SSLCertificateKeyFile /etc/ssl/office/office.jukranpujut.net_tld.key

# SSL Proxy pois
  SSLProxyEngine Off
  SSLProxyVerify None
  SSLProxyCheckPeerCN Off
  SSLProxyCheckPeerName Off

  ErrorLog "/var/log/apache2/collabora_error"
  # Encoded slashes need to be allowed
  AllowEncodedSlashes NoDecode

  # keep the host
  ProxyPreserveHost On

  # static html, js, images, etc. served from loolwsd
  # loleaflet is the client part of Collabora Online
  ProxyPass           /loleaflet retry=0
  ProxyPassReverse    /loleaflet

  # WOPI discovery URL
  ProxyPass           /hosting/discovery retry=0
  ProxyPassReverse    /hosting/discovery

  # Capabilities
  ProxyPass           /hosting/capabilities retry=0
  ProxyPassReverse    /hosting/capabilities

  # Main websocket
  ProxyPassMatch "/lool/(.*)/ws$" ws://$1/ws nocanon

  # Admin Console websocket
  ProxyPass   /lool/adminws ws://

  # Download as, Fullscreen presentation and Image upload operations
  ProxyPass           /lool
  ProxyPassReverse    /lool

I don’t know if the SSLProxy part is needed in this file or not. But anyway I disabled the Collabora server side encryption as told in the guide:

sudo loolconfig set ssl.enable false
sudo loolconfig set ssl.termination true

The Nextcloud log in Admin >> Logging is currently empty, just telling me that Log file “/media/data/nextcloud-data/nextcloud.log” was over 104857600 bytes, moved to “/media/data/nextcloud-data/nextcloud.log.1”

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

valavoja@debian:~$ sudo cat /var/www/nextcloud/config/config.php
$CONFIG = array (
  'instanceid' => 'ocdwbkf3x8o1',
  'passwordsalt' => 'lw4KwN06mNHqHZdyUfccyXq+A4wRbA',
  'secret' => 'w5mHn5mMwE6vC4kBohI+yTHX+tLu85f1oWpnzKtVICjno9zR',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => '',
    2 => '',
    3 => '',
    4 => '',
  'datadirectory' => '/media/data/nextcloud-data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://localhost',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextclouduser',
  'dbpassword' => '[]',
  'installed' => true,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'allow_local_remote_servers' => true,
  'maintenance' => false,
  'updater.secret' => '[]',
  'theme' => '',
  'loglevel' => 2,

The apache error.log gives warning (see below), does it matter? Is it just because the proxy or do I have a problem there? /var/log/error.log:

[Fri Jan 15 13:28:44.856975 2021] [mpm_prefork:notice] [pid 5278] AH00171: Graceful restart requested, doing restart
[Fri Jan 15 13:28:44.934470 2021] [ssl:warn] [pid 5278] AH01909: server certificate does NOT include an ID which matches the server name
[Fri Jan 15 13:28:44.935295 2021] [mpm_prefork:notice] [pid 5278] AH00163: Apache/2.4.38 (Debian) OpenSSL/1.1.1d configured -- resuming normal operations
[Fri Jan 15 13:28:44.935306 2021] [core:notice] [pid 5278] AH00094: Command line: '/usr/sbin/apache2'

The /var/log/apache2/collabora_error is empty.
For some reason I also cant access https :// (it gives the same error than Nextcloud when trying to open a document). So definitely there’s something wrong, but I have no idea where to look for. Please help me!

As an update, seems like I can access my Collabora server remotely. It works like a charm. But somehow it doesn’t work when I try to access it from the same network with the server. What could cause this? As a workaround, I could set up shared folders between NC and local computers, and access those files via local office tools instead of trying to use Collabora tools, and use Collabora only on phone or otherwise remotely/from another network. But it would be nice to understand what causes this.

some router can’t handle access from inside.

so instead of using of did you try the internal IP?


I believe I tried that too, with no luck. And somehow it works with that setting when connected from another network. Anyway I have been planning to invest to a proper router, and I am curious to see how it affects to these things.