Collabora online with built in code server doesn't work

hello, when i try to open a collabora document i get the error message failed to load collabora online please try again later

i followed exactly the steps of this tutorial to install it : https://nextcloud.com/blog/how-to-install-collabora-online-in-nextcloud-hub/ and it doesn’t work :confused:

  • collabora online is installed
  • collabora built in code server is installed
  • the option “use the built in code” is activated

do you know what the problem is ?

i found other reports of the exact same or very similar problem :

some informations :

  • Nextcloud version: 21.0.3 - 21.0.3.1
  • PHP version: 7.3.29
  • Database: mysql 10.2.40
  • Webserver: Apache (litespeed)
  • Operating system: Linux 3.10.0-962.3.2.lve1.5.25.10.el7.x86_64 #1 SMP Wed May 29 04:37:40 EDT 2019 x86_64
  • Collabora Online: 4.2.2
  • Collabora Online - Built-in CODE Server: 6.4.1004
1 Like

Hey Toup,

as you can see my problem has been fixed (see here). I am running a raspberry Pi 4 so this solution is related to running Collabora on an ARM machine!

In short: I had a 32bit OS with an 64bit kernel. This did not work so I switched to an 64bit OS (Ubuntu 20.04.3 ARM64).

I don’t know if this is related: in my case, Apache didn’t work so I changed to NGINX. It works fine.

I remember in older versions of NC/Collabora/CODE Server there was a need for additional webserver rules to get the CODE Server running. Can’t find it for now. In my case I don’t need this. But maybe I remember wrong…

Which OS (Distro) and hardware do you use?
Any Apache/PHP errors /var/log/apache2/error.log ? (no idea where the php logs are located…)

Disclaimer: I’m not a PRO!

hi tompson,
thank you for your answer !

i did see that your pbm was marked as resolved, but your solution seems to imply that you changed your system ? So we don’t know more on how to fix the colabora code server problem, right ?

in my case, i’m on a shared server so i can’t change my configuration easily ! unfortunately i think this is where the problem comes from, i’m going to see how i can figure that out (for exemple, i found out that i don’t have the recommended 512 Mo for php memory)

and i’m going to check on error logs, you’re right, i’ll have to find them !

i’m definitely not a pro :wink:

I agree. My problem has an other source and solution.

Additionally you could check if a firewall is blocking the Codeserver. No idea if this can happen…

For those stumbling upon this post.
The problem is most likely that callabora build in server is made to only use http not https.
If you setup ssl (https) on your server then it will attempt to open the app from the correct host but since it is http instead of https the request is blocked and nothing appears to load.
You can verify this by opening the debug console of your browser and it will show you a Content Security Policy error.

This has been reported to collabora for some time but this is one they apparently wont fix as it would enable more use cases with remote NextCloud hosting.
You can however still setup a separate collabora code service using a reverse proxy.

You have got to be f’ing kidding!?!
No https!?!
This cannot be. I mean, I just can’t accept that any developer would be that stupid.

Hi @Toup

You can refer to the configuration in my article.

Use HTTPS with Ubuntu 22.04, apache, Nextcloud and Collabora(Docker)