Collabora Online translation


I installed loolwsd on a Ubuntu 16.04 server. I followed the Luticius’s guide on Debian Jessie.

The difference is that I built Poco source (complete edition) on the server and I didn’t use the Debian package.

nextCloud runs on a Synology NAS and Collabora Online app works fine except that I have a translation problem with the toolbar.
I used PO files that I transformed in JSON files posted in the “/loleaflet/dist/l10n” directory.

First, I saw this error in the /loleaflet/dist/bundle.js file in the line ““GET”, uri, FALSE);” : “Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience…”

Then I changed the value to TRUE and the error is that the function didn’t load the JSON files in “/loleaflet/dist/l10n” directory : help-localizations.json, localizations.json, etc.

Do you have any idea on how to solve this problem ?

It was a bug and Pranav Kant, engineer at Collabora fixed it. The next release later this week will contain the fix.


I do the change in main.js (I saw the change too in Github) but I still have the same error in the bundle.js file in the line ““GET”, uri, FALSE);” (l10n.js part).

I forgot something ?

Yes I forgot something :slight_smile:

I forgot Python packages, so I installed :
sudo apt-get install python-setuptools python-dev build-essential
sudo easy_install pip
sudo pip install --upgrade virtualenv
pip install polib

And html2po :
sudo apt-get install translate-toolkit

But I still had pb with translation…
So, in the Makefile I moved all build sections in this file first section (.PHONY: build) and I rebuilt loleaflet, and it’s OK, I have the good translation.

However, I still have the same error in bundle.js (Synchronous XMLHttpRequest on the main thread is deprecated…) and a error to load only the help-localizations.json file.

It’s not an error, it’s a warning, and it is in 3rd party js code, so we did not bother.

OK Thank you for your help !