Collabora Online for Raspberry Pi

Hi,

first: im sorry for my bad english
I’m running Nextcloud 10 on my Raspberry Pi (last debian jessie img) and i would get Collabora Online.
I’ve tried the official way from the nextcloud page with the docker image … but the Docker image is not arm compatible.
So, is there another way to bring CODE on my pi ?
Have someone did it ? And have the pi enough power for CODE?

thanks for your answers.

Ooh I’d love to enable this on my Pi3…

Someone out there with a 1, 2, 3 on how to do this?

1 Like

That would be really interesting to know how people got on.

I thought docker worked for the PI now though, just haven’t got my Pi3 anymore to test it.

Well the collabora “Debian Jessie on a RPi2” is nice but nothing on CODE running.
Docker works on a RPi3 alright…

Just no docker CODE working on a Pi. (not arm compatible apparently)

I contacted Collabora through their website contact page asking them about Pi (arm) support … never ever heard from them…

Which is a pity as I really would like to move forward on this.

Its a strange one not to support as Arm servers are making big moves into the data center.

I think the problem is that is a Amd64 bit container and also as well as the architecture change, Raspbian is 32bit.

Might even be more than just recompiling for Arm.

Its also a huge problem for Nextcloud as the next generation 64 Armbian market is going to explode, has already, (Raspbian will go 64bit soon also, prob offer both) .
So I guess there is a lot of SBC / box people wondering what this means and if so, maybe the documents App needs support.

Raspbian may stay as it is, but there are alternative Arm distro’s and you would think maybe they would provide Collabora 2.0 https://www.ubuntu.com/download/server/arm as its well supported and used.

If docker is working on Raspbian now then surely docker pull collabora/code_arm

Did you try the Pi2 Image as dont’ have my Pi3 to try anymore.

I would of thought its just a matter of the reverse and with quemu-x86_64-static binary being copied to the container?

So there is no way right now to run Collabora Online on a Raspberry Pi with Nextcloud?

I find that strange since this press release regarding Nextcloud Box states that NC Box users can install Collabora Online.
https://nextcloud.com/pr20160916/

Doesn’t seem to be from what people are saying, 11 was released on December 13, 2016, your article is from before.
Nextcloud 10 with the documents app runs, but the Collabora docker image is x86 and that is a square peg in a round Pi.

So I need to run a real x86 distro on a Pi3.

You can not run an x86 distro on a Arm soc, you might be able to run qemu in a docker container with collabora as its done on x86 systems running Arm containers. So I guess the reverse is possible, just the hit from emulation rather than native virtualisation.
Emulation is possible, but I haven’t bothered and it would be slower than you already have.

The document foundation have also released an x86 docker container of LOOL https://wiki.documentfoundation.org/ReleaseNotes/5.3#Public_LibreOffice_Online_Docker_image

The easiest way would be for them to also supply an Arm version.

Also its highly likely the support might be only for 64bit if it ever does turn up as it is for x86.

Its also docker pull libreoffice/online:master but its x86 64bit

I keep thinking an alternative is needed and we need some kind dev to pick up the reigns of the Document app as an alternative parallel offering.

1 Like

Hi,

Do you think that installing collabora without docker could work on pi3?
thanks,

Eric

Maybe if you work through the complex compile options and manage to compile in a 2Gb Ram space then yes.
Nobody has though.

What about cross-compiling ? This should work, has anyone tried ?

There is a github issue on the docker image repo of CODE: https://github.com/CollaboraOnline/Docker-CODE/issues/4

dear,
stop compiling collabora.
start using community documentserver
with this topic


i am using it on my rpi4 4gb without any issues.

The docker image of collabora is compatible. Docker probably used the amd64 image instead of arm64. Try to specify the architecture in your docker-compose.yml