Collabora Online Developer Edition 4.0 is here: edit documents on mobile and more!


#21

In the iOS app it works with no problems. Anroid the same “open with”


#22

There came a few points together:

  • support for mobile editing / responsive design was only added in 4.0 RC2
  • RichDocuments app (nextcloud) was missing this check
  • a bug on Android Files app will lead always to ignore Collabora editing

So, you would need 4.0 RC of CODE, latest RichDocuments and a new version of Android, which will be released today/tomorrow.

I want to apologize for this. We tried to get every part ready on its own, so that it works directly when all needed components are available, but this idea failed…


#23

I think the main source for confusion was not that the parts where not ready all at the same time but that the announcement of the availability of the feature was published days before the actual availability. Maybe this can be timed a bit better in the future as it saves people from spending time debugging their setup and finding out what is missing :).


#24

Thanks for making things clearer. So I’m looking forward for the next versions, as I’m excited to try out the new features!


#25

I don’t understand, so editing in mobile app is not ready yet, isn’t it?
Thanks in advance

PS I’ve tried Nextcloud Dev App and it does not work either.


#26

When will CODE 4 RC2 be released so we can test this?


#27

Thanks. We have the time to wait. Merry Christmas.


#28

Thanks for the heads-up. Nextcloud 15 and CODE 4 are amazing nevertheless. Big thanks to everyone involved!


#29

Android Files app 3.4.1 RC2 is out for Google Beta user.
Can you please test and reply, if it working now for you?


#30

Just checked - 3.4.1 RC1 is only available for me. With that the same result as before. 3point menu does not give “Open with” as an alternative. After downloading “open with” is shown, but it deos not say “Open with Collabora”. If I choose open with the file opens in Microsoft Office. There is also no possibility to create a new file.
Will look for the RC2.


#31

I now use RC2. Get the same result.

Skickat från min Samsung Galaxy-smartphone.

-------- Originalmeddelande --------


#32

Not working. Nextcloud 15, Collabora 4 Docker, Android 3.4.1 RC2 - Huawei P9lite


#33

Thanks for trying.
Now there is RC2: https://www.collaboraoffice.com/code/

Can you try it with this one?

You can verify if CODE is ready for mobile editing when checking this site:
https://$yourCODEinstance/hosting/capabilities

It should then show:
{“convert-to”:{“available”:false},“hasMobileSupport”:true,“hasTemplateSaveAs”:true}

If this is shown and Android File App is still not showing up editing, can you then please create me a test user on your instance and I’ll check it.


#34

Yeah now it working.

My misstake was the missing ProxPass for hosting/capabilities in the apache site config.
Now it working.
Code RC2 / NC15 / Android App 3.4.1 RC2

Thanks.
Merry Christmas


#35

Thanks for the hint, Matrix114, working here too.
For everyone else: you need to add the following lines to your Apache site config file:

ProxyPass           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
ProxyPassReverse    /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

Maybe this could find it’s way into the manual at https://nextcloud.com/collaboraonline/


#36

Many Thanks!! That was the solution to the problem.

Merry Christmas!!!


#37

I added the following lines to my nginx configuration:

 #Enable mobile editing feature
    location ^~ /hosting/capabilities {
        proxy_pass https://localhost:9980;
        proxy_set_header Host $http_host;
    }

And now I can see the following:

code_mobile_editing

But unfortunately it still doesn’t work. :sob:

@tobiasKaminsky Thank you very much for your offer. I will send you an test account.


#38

Thanks, I was comparing my apache config with https://www.collaboraoffice.com/code/apache-reverse-proxy/ and came to the same conclusion.

Note for anyone using the package repo install (non-docker):
Check /etc/loolwsd/loolwsd.xml and compare it with loolwsd.xml.dpkg-dist (i’m running Ubuntu). During loolwsd package upgrade, default is to keep the current file. New or changed settings won’t be updated automatically, so you have to migrate them manually into your current file.
Maybe better: use loolwsd.xml.dpkg-dist as base and edit it to your needs.

Tested with:
Nextcloud 15.0.0.
CODE 4.0.0 (git hash: 173510f)(this is RC2, package install on Ubuntu 18.04.1)
Android 3.4.1 RC2

Open with Collabora menu is working. Nice! :christmas_tree:


#39

Wow, i just added the nginx config to my NC 14.04 installation and the editing works in the Android 3.4.1 RC2!

I have:
NC 14.04 (installed from the zip file from the site)
CODE installed from the Debian repo (version 4.0.0-4)
Richdocuments 3.1.0
Android Client 3.4.1 RC2

I would have liked to add a screenshot but it seems the Android app forbids screenshots…


#40

Has the same Problem. Any workaround for users with Ngnix Webserver?