Collabora Online Developer Edition 4.0 is here: edit documents on mobile and more!


#41

Thank you all for trying Android Files App 3.4.1 RC2.
Then I’ll release it now as stable.


#42

What’s happening with Nginx users?

I get only this message when I open cloud.domain.tld/hosting/capabilities


{"convert-to":{"available":true}}

#43

Tuning my nginx config fixed it for android app editing. Thanks for that feature, it rocks.

Now, how to get the Talk sidebar in collabora web ?


#44

Could you check if you used the right domain? That was one of my faults. I first used cloud.domain.tld instead of CODE.domain.tld e.g. office.domain.tld. So you need to use the domain you set up for your Collabora CODE instance and not the general one for your Nextcloud.

And before you have to insert the following lines to your nginx config file. Of course after making a backup of the config file :grin:

 #Enable mobile editing feature
    location ^~ /hosting/capabilities {
        proxy_pass https://localhost:9980;
        proxy_set_header Host $http_host;
    }

Hope this will help.


#45

Thanks for your answer but the same result when i open office.domain.tld/hosting/capabilities

{"convert-to":{"available":false}}

#46

I used the Collabora on my smartphone(any web browsers) and the display will zoom. For example, the menu bar of NC also changes more than twice as large. My general problem is that much.

My big problem is that I can not enter 2-byte characters. This may be a very difficult hope of realization.

As my trivial request, when we open MS office data, we want to have ‘reader mode*’ to prevent destruction of form(design collapse). *Just open it and do not save it.


#47

I managed to get mobile editing working. I also missed to update my reverse proxy (nginx) configuration - after I did it, it worked. This thread was valuable resource in debugging this - thanks to everyone!

However, I noticed that I have “Open in Collabora” option only for OpenDocument files, ie. it’s not available for MS Office files. Is this expected behaviour?


#48

Did you check your are running the latest CODE Version? At least 4.0?


#49

Yes i downloaded with

docker pull collabora/code

And

docker pull collabora/code:4.0.0.2


#50

I am having the same issue as you.

  • Latest CODE Docker image
  • Latest Collabora app
  • Latest NextCloud Android app
  • NGINX configured as stated above

…and still, only {"convert-to":{"available":false}} appears at the https://office.domain.tld/hosting/capabilities endpoint.

Keeping an eye on this thread for a solution.


#51

Okay, i fixed it for me.
I stop the container and execute following command.
make sure all needed containers running!

docker images prune --all

After that I running

docker run -t -d -p 127.0.0.1:9980:9980 -e "domain=cloud.domain.tld" 
        -e "username=admin" -e "password=S3cRet" --restart always collabora/code

#52

I’m behind an apache proxy and do face the same problem. I was able to fix it by adding the following lines to my Apache config:

  # WOPI capabilities URL
  ProxyPass           /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities retry=0
  ProxyPassReverse    /hosting/capabilities https://127.0.0.1:9980/hosting/capabilities

I guess the documentation at https://nextcloud.com/collaboraonline/ should be updated accordingly?


#53

Awesome, that fixed it for me too. So this was probably a Docker issue rather than a Collabora/CODE issue.

Thanks!


#54

Yes, I think it’s an docker issue. I think this note should be included in the tutorial.


#55

The addition to the nginx config worked for me.


#56

Hello, I managed to get this working using the nginx configuration script; however the question I have is regarding group folders. I can happily open with collabora when working in a standard folder, but get a circle of doom when trying to open from a group folder. Infuriatingly, it is when I am working on a document in a group folder that I would like this to work!
The documents open happily from the nextcloud website: just not from mobile. Has anyone else got this issue or have a workaround?


#57

After the Collabora update today, group folders are now working. Thank you Collabora and Nextcloud!


#58

Grate news can start looking to updating again. :+1:


#59

CODE 4.0 doesn’t work with a reverse proxy on a custom port. It is already fixed upstream, now hopefully they can publish a new RC that fixes this problem.


#60

Today I would use the editing in the nextcloud app, but suddenly it won’t work anymore… It downloads the document.