Collabora Online 1.8 with LO 5.1 and new features

Second edit: Would it be possible to use a self singed SSL cert?

Let’s Encrypt FTW. :wink:

I have a different setup, maybe you have an idea:
Collabora Container exposes now TCP 9980.
My Docker runs on a different machine than Nextcloud. Both hosted at the same provider.
So, I wanted to install the stuff using ACME as shown in the Video of Jos. But the config changed (ports), I guess and I do not know, which installation mode is needed regarding the reverse proxy and ACME.
Any link I can refer to?

@enoch85 I know, reason is I already have that implemented in the auto install. But if its not a must then I’d rather leave it out since using snakeoil is a lot more fail proof then using letsencrypt.

@ezraholm50 How can snakeoil be more failproof?

I recently made a script to setup my Nginx Reverse Proxy Hosts that implements a secure SSL setup. Check it out and get some inspiration:

It works without any issues at all. It would be asy to adopt to Apache as well. Just change the secure settings and different headers in the virtual host file.

@enoch85 It is because of the letsencrypt part in the script. If the user doesn’t have 443 forwarded or apache2 is still running the cert wont be created.

I’ll have a look later tonight. Used your previous version I think so I’d be comfortable with it I guess.

@ezraholm50 Yeah, didn’t think of the 443 thing. Apache is easy, just stop it before the cert is generated.

We could at least ask the user if they want to get a real cert, then we could use the script we already use, and just change the domains to several instead of just one. We are aiming for the best possible solution here. :slight_smile:

I’m getting a docker error when trying to start the new container. This is on CentOS7 based machine.

docker: Error response from daemon: failed to create endpoint kickass_lumiere on network bridge: COMMAND_FAILED: '/sbin/iptables -w2 -t nat -A DOCKER -p tcp -d --dport 9980 -j DNAT --to-destination ! -i docker0' failed: iptables: No chain/target/match by that name..

You have to systemctl restart docker to get it to recreate the iptables rules, its a known docker bug with firewalld.

1 Like

Speed has improved, that is very nice.

But, it still fails to open documents with accents in their name (eg. testé.ods):

kit-00391-04 00:07:59.855309 [ kit_queue_0004 ] Failed to load: file:///user/docs/391/test%C3%A9.ods, error: Unsupported URL <file:///user/docs/391/test%C3%A9.ods>: "type detection failed"

The exact same doc renames to remove the accent loads fluently.

I try to place my question again with a picture:

Point is, that I can configure the collabora plugin in Nextcloud and I can jump to the Documents-Section where I can see possible editable docs, but as soon as I want to open a doc the request times out.

Hope you guys can help.
Thanks in advance.

Have you seen this?

I’ve got it working this way but to comment on the picture: place the Proxy on the right side, not on the Collabora-Docker-Side!

Can anyone who’s installed this and got it working tell me if the document editing GUI is mobile friendly? Is there a demo server we can try?

@lebernd: So on the docker side there is no Apache needed at all? When looking at the config for the virtual host, it seems it wanted to have its own subdomain as of:
<VirtualHost *:443> ServerName

I really do not understand, why I need a new virtual host on the right side with its own subdomain. Does the proxy need this? … well, would be my first working Apache proxy…

Did you solve the problem you had referring to you post in the chat mentioned?

you can have access to a demo server here:

Right, no additional apache on the docker side needed.

Just configure the ssl-proxy.conf as mentioned in the tutorial and replace the localhost entrys with the IP of the server where docker container get exposed.

Actually, it was my first working proxy too :slight_smile:

No, I didn’t get rid of the 20 seconds with the docker image. But the tutorial to extract the files is pretty good.

please, if you see issues - filing a PR is absolutely the best thing you can do… Thanks a LOT!

it is kind-of doable but not great.

Yeah, I just tried the test server and I agree with your assessment. On the one hand, you can technically click on and do everything. On the other, you often have to scroll to get interface elements onscreen.

Ah well. I look forward to the day when either Collabora has a mobile interface, or the NC client can do full 2 way sync, so I can use a local app to edit documents. Until then, I guess I’ll just use the one way sync, and occasionally manually re-upload the edited files.

Still, Collabora is an impressive step forward for the free software world! I’m looking forward to being part of it’s evolution…

1 Like

I’m also trying to install this docker image on my system that looks like this:

Nginx Reverse Proxy: (Handles all the SSL and HTTP requests and send them to the correct backend)
Apache2 backend with both Nextcloud and Docker image:

Now, how do I configure this? My Nginx Reverse Proxy sends everything over HTTP as it’s internal traffic on the server, but the configuration for Collabora demands SSL. My Nginx Reverse Proxy handles the SSL requests (I have Let’s Encrypt on Nginx and not my backends i.e.) and I can’t add a virtual host in Apache (backend) as it only gets HTTP traffic from the proxy.

I tried a few scenarios, but I’m stuck. Would really want this to work. Thanks!

Any update on this matter?