Collabora on Debian 8.x - anyone got it working, if yes how?

@MikeLupe

Did it worked for you ?

@faisalna yes, it finally did work.

I still have the :80 http redirect to :443 https, didn’t try it without yet.

ahh , but are you able to open documents ? or nope ?

Am trying to setup it on debian

@faisalna as I wrote - yes, everything works.

Sometimes (not often at all) I still get “connection error, try again”, but only when I’m stressing the app a lot (fast changes on edit/view mode) OR every time when I try in a text document to jump from an index to the respective chapter - then it opens a new browser tab and gives me the error.

But again - it works with all the functions (all those I tried).

@MikeLupe

Thans mate, let me try on my side as well and will update you asap

Oky, good luck - it would be about time for you to feel this moment of eternal victory when it works… it was like winning a gold medal :wink:

And coincidence was, at the same time I finally managed again (after several weeks) to make MS Office 2007 running on Wine (PlayOnLinux;) on my newly reinstalled Debian Notebook.

I tell you man - it was like taking the next step to existence, really - couldn’t believe it :wink:

wow… that is niceeeeee , I would love to know how

Give updates on your work, we will make it work :slight_smile:

Can this be run behind another NGINX reverse proxy? How would I configure that proxy to handle both next cloud and collabora in the VM?

I want to add a few things I came across trying to get it all working under Debian 8:

  1. Certs:
    Certificates are needed to get it correctly working. I didn´t find any explanation for self-signed ones, so I got ahead with “real” ones. I was missing a certificate. I used a checker to find this out: see https://cryptoreport.rapidssl.com/checker/views/certCheck.jsp

  2. Kernel:
    I came across the problem that Collabra itself was working, but I could neither open uploaded documents nor ones directly created with it. This was because of the missing aufs support of the kernel I was using under Debian 8. I read quite some posts about this issue - somewhere, I read that a possible solution was to switch to overlay/overlay2. But I was using Kernel 3.16 and overlay is only supported with 3.19, so anyhow, I had to update the kernel - because 3.16 did neither have support for aufs and overlay. Switching to devicemapper even seemed to be more complicated: I found a step-to-step howto (see https://docs.docker.com/engine/userguide/storagedriver/device-mapper-driver/), but I didn´t have any block device for that. So I kept on searching for solutions to update the kernel. What I did: Switched to liquorix kernel (see https://liquorix.net/). Sure, this is certainly not the best solution in terms of security etc. But all other things seemed to be quite a hard work.
    I have to add that I had to install testing gcc-5 on the system, because the headers of the liquorix kernel are depening on this (see http://unix.stackexchange.com/questions/284817/how-to-install-gcc-5-on-debian-jessie-8-1/290021#290021). This is clearly a no go for wide productive systems up to now, but I can tell that under the line, all works fine up to now.
    Let me add that I was confused at some point because I am not that deep into storage-driver technology. On some sites, you may read that aufs is no longer supported, other say that newer kernels are not yet supporting it: This does not help to understand if aufs is something that shoud be used if we´re talking about long running systems.
    If anybody has thoughts on this, please feel free to comment :slight_smile:

  3. App:
    The app seem to be still “experimental” up to now. I had to download it (see https://apps.owncloud.com/content/show.php/Collabora+Online+connector?content=174727) and install it myself. If there is any easy solution, please just add.

As a resume, I can say that it will work. But the important point is certainly the used aufs from docker. This is something which should be made clear - to me it seems that there is no real easy solution up to now.

Greets,
Michael

1 Like

@icewind wrote a general guide for nginx proxies.

https://icewind.nl/entry/collabora-onlinene

Just wanted to let you know that finally Collabora Online in Nextcloud 10 works as expected on my Debian Stretch system. The update of Collabora Online App (Richdocuments) from 1.1.7 to 1.1.9 fixed the last issue for me, see #4481: Failed to get LoKitDocument instance

By the way, I still use the Collabora Online Docker container and I don’t use aufs. In Debian Stretch (with Linux kernel 4.7), AFAIK Docker uses the overlay storage engine per default. And apparently that works well with the Collabora Online Docker container.

So the bottom line is that I run a Debian Stretch VM (Linux kernel 4.7) with Nextcloud 10, latest Collabora Online Docker container and Richdocuments/Collabora Online App 1.1.9. The Apache VHost is configured according to the offical docs: Collabora Online in Nextcloud. I have HTTP->HTTPS redirection enabled and use LetsEncrypt SSL certificates for both the Nextcloud and the Collabora VHosts.

Hi Mike,

It does not work for me still. :frowning:

Any help please

Hi @faisalna,

unfortunately all I can do is describing to the best my working setup:

  • Debian Jessie 8.6, backported kernel 4.7.x.bpo
  • 2 vhosts in Apache, letsencrypt for both
  • PHP 5.6.26, MariaDB 10.x…
  • Nextcloud 10.0.0.RC1
  • Docker 1.12.2
  • Collabora nextcloud app not restricted to any groups

I think I had the issue of needing to restart the docker service after a reboot of the server - I guess because of some problems with the firewall. Docker adapts the system firewall when starting. But don’t nail me on this one :wink:

I’m afraid I can’t help much further - here you would really need the dev’s help…

Mucho luck!

I followed this guide but at first it was not working. The update today of the connector from 1.1.9 to 1.1.10 seems to have fixed my issues!

Great - can anyone else confirm the update to 1.1.10 helped?

Sometimes it loads documents, sometimes it doesnt. It’s moody.

Got Working the platform perfect.
No Docker needed
Ubuntu 16.04
Installed Require Libraries Manually
Reverse Proxy on Apache with legitimate certificates.
loolwsd.xml file modified accordingly.

To-do
Now to test on Debian.

Ubuntu 16.04
automatic script