Collabora Office not working Reverse Proxy

Hello there,

I am having trouble using Collabora (Nextcloud Office) in NC. When I open a (for example) docx file the Nextcloud interface returns a Could not open. I have seen this error on the internet a lot, but couldn’t find a solution that fits me
For the record; I am using a Reversed Proxy (Apache) in front of my Nextcloud instance (Apache).

This is my setup:
Reverse Proxy: Linux Ubuntu 22.04 / Apache 2.4.52
Nextcloud: Linux Ubuntu 22.04 / Apache 2.4.52 / Nextcloud 25.0.3 > Firewall > Reverse Proxy > Nextcloud
I am using the Collabora CODE Builtin server of Nextcloud. When setting the server settings in Nextcloud, it says that the CODE server is reachable.
When opening Nextcloud connecting to the server directly (using the hostname instead of domain), Nextcloud Office does work. So the problem seems to be in the reverse proxy somewhere.
I have tried enabling a lot of things in Apache or the vHost config file, but nothing helps. I have enabled mods: proxy, proxy_http, proxy_html, proxy_express, proxy_fcgi, proxy_connect, proxy_wstunnel.
The richdocumentscode url is set to

Does anyone know how to fix this / can anyone help me?
Thanks in advance!

Did you double check if you’d restricted WOPI access to a specific subnet or host?

occ config:app:get richdocuments wopi_allowlist

take a look at this article, this has lot of hints included Nextcloud Collabora integration

1 Like

Thank you for your reply, I have checked en set this on

Thank you for your reply.
I have read the article but this is about separate installations of Collabora or other similar apps. My issue is with the built-in CODE Server in Nextcloud. So I taught that the article was not applicable for my issue?
As URL I have used the same URL of the Nextcloud instance, reachable and working. The SSL Certificate of the nextcloud instance is a self-signed certificate. The Reverse Proxy does encryption with a CA Signed Certificate. So that the front-end is clean from errors, but the back-end doesn’t matter (I think).
When using the status url I get an expected OK message.

built-in CODE is similar to separated instance, just running behind specific URL /apps/richdocumentscode/proxy.php lot of steps apply to both variants. you are welcome to extend the wiki with built-in specifics.

I solved my problem by just installing the Collabora Online server.
Thanks for the responses!