Collabora Office 6.4-45

Meine Konfiguration:

Ubuntu 18.04 4.15.0-151-generic
PHP 7.4.21
mysql 5.7.34
Apache/2.4.29 built: 2021-06-18T11:06:22
Nextcloud 20.0.11
Collabora:
LOOLWSD
6.4.10
LOKit
Collabora Office 6.4-45

Nach dem letzten Collabora-Update (auf Version 6.4.10.45-45, am 20.07.2021) wird kein LibreOffice-Dokument mehr geladen. Der Ladebalken bleibt bei 0%.
loleaflet/dist/admin/admin.html ist weiterhin erreichbar.
In Nextcloud wird mir unter settings/admin/richdocuments “Collabora Online Server ist erreichbar.” angezeigt.

‘systemctl status loolwsd.service’ zeigt folgendes an:
WRN Failed to verify the certificate of | ./net/SslSocket.hpp:193
ERR WOPI::CheckFileInfo failed for URI [removed/index.php/apps/richdocuments/wopi/files/267374_octv6b4xcq6s?access_token=pGzQUA7NSUJTFrIJDwfAd5yKdxvpBIla&access_token_ttl=0&permission=edit]: 0 . Headers: Body: | wsd/Storage.cpp:703
ERR loading document exception: WOPI::CheckFileInfo failed: | wsd/DocumentBroker.cpp:1893
ERR Failed to add session to [/index.php/apps/richdocuments/wopi/files/267374_octv6b4xcq6s] with URI [removed/index.php/apps/richdocuments/wopi/files/267374_octv6b4xcq6s?access_token=pGzQUA7NSUJTFrIJDwfAd5yKdxvpBIla&access_token_ttl=0&permission=edit]: WOPI::CheckFileInfo failed: | wsd/DocumentBroker.cpp:1855
ERR Storage error while starting session on /index.php/apps/richdocuments/wopi/files/267374_octv6b4xcq6s for socket #25. Terminating connection. Error: WOPI::CheckFileInfo failed: | wsd/LOOLWSD.cpp:3592
WRN Ignoring attempted read from 25| ./net/Socket.hpp:1021
ERR Invalid or unknown session [069] to remove.| wsd/DocumentBroker.cpp:1932
DBG child_ws: recv [exit | kit/Kit.cpp:2108
INF Terminating immediately due to parent ‘exit’ command.| kit/Kit.cpp:2161
WRN Prisoner connection disconnected but without valid socket.| wsd/LOOLWSD.cpp:2231

Im Moment habe ich keine Ahnung woran es liegen könnte.
Vielleicht weiß jemand was da los ist oder wie man auf die Version vor 6.4.10.45-45 zurückgehen kann.

1 Like

ich habe gleiches/vergleichbares Problem:

ich habe das Gefühl das hat etwas mit IPv6 zu tun… Ich habe auf Github gelesen dass DNS mit ausschliesslich A records funktioniert während AAAA und andere zum einem (anderen) Problem führen… habe bisher aber keinen eigene Lösung…

Vielen Dank für Deine Antwort. Mich irritiert eigentlich die Warnung “Failed to verify the certificate of…”, da ich ein Zertifikat von Letsencrypt benutze, das noch bis Mitte September gültig ist. Sei es wie es ist, ich will nicht die Probleme von Nextcloud/Collabora lösen. Deswegen würde es mir völlig reichen, wenn es einen Weg gäbe zur vorherigen Version zurückzugehen, wie es eigentlich mit dem apt-tool auch gehen sollte. Nur scheint das bei Collabora nicht so einfach zu sein …

Hmmmm, ich habe auch plötzlich Schwierigkeiten, die ich mir nicht erklären kann: Collabora stopped working on two of my instances, failed to load document - :information_source: Support / :page_facing_up: Collabora - Nextcloud community

Ich habe 14 wöchentliche Backups und gehe mal sukzessive rückwärts, vielleicht liegt es ja wirklich am Collabora-Server …

Vielen Dank für Deine Antwort. Tja ich habe mir gedacht, alles was ich aus einem Repository zurückholen kann brauche ich nicht zu sichern. Wie man sieht hat mich aber die häßliche Realität eingeholt.

Ich bestätige nun ein Problem mit Collabora selbst. 28 Tage zurück auf die Sicherung von Ende Juni und alles läuft wieder. :face_with_raised_eyebrow:

Kannst du nachschauen welche Collabora-Version die funktionierende ist und hier mitteilen?

Jede vor Collabora Office 6.4-45 sollte funktionieren. Leider ist in dem Collabora Repository anscheinend nur diese vorhanden. Jedenfalls habe ich nirgends eine frühere Version gefunden.

Danke. Hab es gerade mal mit dem Docker container versucht und das funktioniert: docker pull collabora/code:6.4.10.4

Ich habe heute ein update für loolwsd und code-brand eingespielt, danach hat sich der loolwsd-server erst mal verhaspelt. Ich mußte ihn mit kill -9 abschiessen und dann neu starten. Danach funktionierte Collabora wieder problemlos. :grinning:

1 Like

Die Sicherung, die ich wieder eingespielt habe, ist diese Version:

Versionsinformationen

LOOLWSD

6.4.9 (git hash: 0b3211b)

LOKit

Collabora Office 6.4-41 (git hash: adfa130)

Alles danach hat 'ne Macke bei mir.