Collabora Nextcloud integration - requesting adress is denied wsd/ClientRequestDispatcher.ccp:481


I have a problem with the Collabora Nextcloud integration. I have a Collabora docker document server running on Unraid. It worked like a charm for a long time. But recently it broke. In the browser Nextcloud does not open any files (office, pdf’s, etc.). It just does not do anything.

Everytime I try to open a document I get in the Collabora docker log the following: wsd-00001-00063 2024-05-29 10:30:00.809690 +0200 [ websrv_poll ] WRN convert-to: Requesting address is denied: ...*| wsd/ClientRequestDispatcher.cpp:481

strange thing is it works in the iOs app on my iPhone. I can edit and open .xml, .doc, and other files. The Nextcloud office app says green lights and that the server is reachable. When I open a document in iOs, the Collabora server states that a user is using the document server.

I have searched the forum but cannot find any solutions.

Can someone help?



I have the same error, but everything is otherwise functioning appropriately. (I can open, edit, save files). I also see errors about systemplate directory being read-only and etc/hosts being out-of-date.

Which version of Nextcloud are you using? Which version of Collabora?

Ok, thanks for replying. The weird thing is I can open, edit, and save files in the iOs app on my iPhone. But in the browser it just starts downloading the file instead of opening it in Collabora. When I do ‘right-click - edit in office’ nothing happens, and the error appears in the log of the Collabora dockercontainer.

I have nextcloud version 29.0.1. Collabora version is 594b605. Both the latest I think.


Do you use a different hostname for your nextcloud server in the iOS app than in the browser? I ask because in Collabora every hostname that is allowed to use Collabora must be allowlisted.

I use the same hostname for my iOs app as in the browser.

What kind of web server do you use for Nextcloud and as a Proxy for Collabora?

I use a reverse proxy for nextcloud and collabora with a Swag dockercontainer. They are subdomains in cloudflare.

I hope you can help me, I can’t figure it out by myself :slight_smile:

Have you entered the IP addresses of your Collabora under “Allow list for WOPI requests” in settings → administration → office in your Nextcloud? If so, it would be interesting to see if it works if you don’t enter anything there (not recommended, enter again afterwards).

I left it blank, so I haven’t put an IP adress there. I am also not really sure which IP adress to put there. Just the internal IP adress of my unraid server and the correct port?

The address from which the Collabora WOPI Request comes :slight_smile:. I would check the access logs from the Webserver/Proxy which serve nextcloud to see if you can see the IP address from Collabora anywhere. This can be an internal address or an external one, depending on the setup. But if this field is currently empty, then this should not be the cause of your problem, but you should still fill it for security reasons … But I’m sorry, I can’t think of any more ideas at this point.


‘Allow list for WOPI requests’

Hope that helps.

Much and good luck,

1 Like