Collabora ignores logging.level


I run collabora code in container under podman. I can’t help it spamming the logs, I wonder if someone could spot my errror. I launch it with this environment extra options:

-e "extra_params=--o:ssl.enable=false --o:ssl.termination=true --o:logging.level=4" -e "dictionaries=en_US fi_FI"

First I tried with logging.level=warning, but it won’t reduce them either. I see all debug and trace and info levels, which is a lot.

This is what the coolwsd.xml says about logging option:

    <color type="bool">true</color>
    <level type="string" desc="Can be 0-8 (with the lowest numbers being the least verbose), or none (turns off logging), fatal, critical, error, warning, notice, information, debug, trace" default="warning">warning</level>

So it should be even warning by default, but no, it spams a lot. I haven’t yet given up and mounted the xml file into container.

Never mind. The answer was the next line in coolwsd.xml which I didn’t concentrate on:

<level_startup type="string" desc="As for level - but for the initial startup phase which is most problematic, logging reverts to level configured above when startup is complete" default="trace">trace</level_startup> 


1 Like