Collabora from packages and Apache with HTTP/2

I have Nextcloud running on my home Ubutnu 18.04. Just gave a go with Collabora but I wished to install this using deb packages instead of Docker. Quick installation on virtual machine was successful (self signed certs and no HTTP/2) so I repeated this on my working server but no success. I can’t get the Collabora to work. My guess is the HTTP/2 and reverse proxy but I’m not sure any more and to be honest, got stuck.
Apache2 config for Collabora:
Apache2 config for Nextcloud:

You do know that there is more to configure? In directory /etc/loolwsd did you configure loolwsd.xml? And which certs did you use for loolwsd.xml?

Cheers @peteman52. Here is my loolwsd.xml. I used the same certs as for the collabora domain.
I literally just fixed it - I assumed that, I’m using HTTP/2 so I tried to use proxy_http2 . Long story short - changed to proxy_http and it’s working!
Btw, how to change language or add more languages to it? I only have “english_us”

Ok, I figured this out as well - I was missing deb package - hunspell-en-gb (for example)