Collabora Font Issues

Greetings all. I am working on getting a fully functional NextCloud build but I am having a few issues regarding fonts; curious if anyone has encountered this or has a solution/place to look.

My Build:
NextCloud is run on a root access Cpanel on a VPS
Collabora is installed on the Admin panel
My collabora server is built on Ubuntu 16.04 via docker on an AWS EC2 cloud

Everything was working perfectly.

Problem is adding additional fonts. The fonts show up in the Collabora window when I want to type the documents, but two issues arrive:
1.) When one of the installed fonts is selected, the cursor vanishes
2.) All text of that font also vanishes.

I have verified the text is still there, but completely hidden.

The fonts I have installed are the MS core fonts:
I first installed them on the EC2 then I moved them into the docker container. Once in the docker container, I have run fc-cache IN THE CONTAINER and verified with:

docker -exec -t {container} fc-list

(after a reboot)

The fonts do appear in the pulldown.

I thought it may be related to the MS fonts, so I grabbed another font (another .ttf) and repeated the process. That font also appears in the list but the same problem occurs.

Some thoughts:
1.) Is it related to these being .ttf fonts? - Perhaps I will repeat the process with a non-ttf to test those results
2.) Would this be the correct procedure to add additional fonts?
3.) Anywhere else I should be looking?

Hi, did you solve your problem ? I have the same one on my install.
:up:

@DylannCordel @tomstl Make sure the fonts are copied to /opt/lool/systemplate/usr/share/fonts as well and readable by all users.

Assuming you’re adding the fonts during Docker container build, add the following file to your Collabora CODE Dockerfile somewhere after RUN bash install-libreoffice.sh :
RUN chmod -R a+r /usr/share/fonts/* && cp -rv /usr/share/fonts /opt/lool/systemplate/usr/share

Hi! Thanks for the suggestion, which did not work for me, though.

My docker container collabora/code:latest seems to pick up only the fonts in /opt/collaboraoffice6.0/share/fonts/truetype. What is good though, subdirectories of that path are also searched.

So what worked for me was adding a docker volume (add option --volume "/usr/local/share/fonts/:/opt/collaboraoffice6.0/share/fonts/truetype/local/:ro" to the run command or the docker-compose.yml file) which includes a font collection from the host under that directory.

Hope this helps someone.