Collabora fails cURL error 7: Failed to connect

Hi all,

So im follwing this guide https:// nextcloud. com/ collaboraonline/ to get collabora working on my owncloud.

now my domain for owncloud is and collabora is

I have my docker running:

0369e5983530 collabora/code “/bin/sh -c 'bash sta” 24 hours ago Up 24 hours 9980->9980/tcp peaceful_fermat

Here is the apache conf file

<VirtualHost *:443>
ServerName office. dingit .dk:443

SSL configuration, you may want to take the easy route instead and use Lets Encrypt!

SSLEngine on
SSLCertificateFile /etc/letsencrypt/live/
SSLCertificateKeyFile /etc/letsencrypt/live/
SSLProtocol all -SSLv2 -SSLv3
SSLHonorCipherOrder on

Encoded slashes need to be allowed

AllowEncodedSlashes On

Container uses a unique non-signed certificate

SSLProxyEngine On
SSLProxyVerify None
SSLProxyCheckPeerCN Off
SSLProxyCheckPeerName Off

keep the host

ProxyPreserveHost On

static html, js, images, etc. served from loolwsd

loleaflet is the client part of LibreOffice Online

ProxyPass /loleaflet https:// loleaflet retry=0
ProxyPassReverse /loleaflet https: // :9980/loleaflet

WOPI discovery URL

ProxyPass /hosting/discovery https :// :9980/hosting/discovery retry=0
ProxyPassReverse /hosting/discovery https: // :9980/hosting/discovery

Main websocket

ProxyPass /lool/ws wss: // :9980/lool/ws

Admin Console websocket

ProxyPass /lool/adminws wss:// :9980/lool/adminws

Download as, Fullscreen presentation and Image upload operations

ProxyPass /lool https:// 9980/lool
ProxyPassReverse /lool https :// 9980/lool
ServerAlias office. dingit. dk

I have tried to disable the firewall
I ave tried to disable the apparmor
I have tried with the Collabora app in nextcloud to both use :443 and :9980 no change. I evne tried without using any ports and just the URL

I chose lets encrypt for SSL but im not using ACME. I just followed the guide from lets encrypt on ubuntu 16.04. but from the looks of the conf file it looks to right.

My problem is i keep getting this error when i open a .docx file in owncloud:

Collabora Online: Cannot connect to the host “https:// office.”. Please ask your administrator to check the Collabora Online server setting. The exact error message was: cURL error 7: Failed to connect to port 443: Connection timed out

can anyone help me here?

don’t mind the spaces in the URLs. as a new user im only allowed to post posts with two links in them…

see the troubleshooting section - did you start docker with the right URL? Tripple-check, it did cost me a full day before I found out that that was the problem :wink:

Hi Jospoortvliet,

Sorry for the slow respons :slight_smile: but i have been a busy little bee :slight_smile:

Yes i did tripple check this specifik thing and i did remember you mention it in your youtube video.

But just to be clear in my case this would be line right?

docker run -t -d -p -e “” --restart always --cap-add MKNOD collabora/code

since my nextcloud server is - or should it be

I found the problem. And it had nothing to do with nextcloud. I have a edge firewall which was not NATing port 9980 to the nextcloud server… which you need :slight_smile:

dear sir how did you solve your problem can you show a little bit please
many thanks

i can try…

my nextcloud server was behind a firewall. This firewall had opend port 443 so that i could access my nextcloud servers webinterface and with my windows client.

but i hadn’t opend port 9980 which collabora is using and so my firewall was blocking. adding a allow rule for port 9980 solved my issue