Collabora: Failed to load the document (All Logs included)

Hello Nextcloud Community,

i have the following problem: I can’t open any Document with Collabora online in Nextcloud!

Docker Log:

wsd-00025-0026 21:18:09.376184 [ client_req_hdl ] WRN  WOPI host did not pass optional access_token_ttl| wsd/FileServer.cpp:255
    wsd-00025-0029 21:18:10.257934 [ client_ws_0009 ] WRN  Missing JSON property [HidePrintOption]| wsd/Storage.cpp:353
    wsd-00025-0029 21:18:10.258053 [ client_ws_0009 ] WRN  Missing JSON property [HideSaveOption]| wsd/Storage.cpp:353
    wsd-00025-0029 21:18:10.258104 [ client_ws_0009 ] WRN  Missing JSON property [HideExportOption]| wsd/Storage.cpp:353
    wsd-00025-0029 21:18:10.258158 [ client_ws_0009 ] WRN  Missing JSON property [EnableOwnerTermination]| wsd/Storage.cpp:353
    wsd-00025-0029 21:18:10.258212 [ client_ws_0009 ] WRN  Missing JSON property [DisablePrint]| wsd/Storage.cpp:353
    wsd-00025-0029 21:18:10.258255 [ client_ws_0009 ] WRN  Missing JSON property [DisableExport]| wsd/Storage.cpp:353
    wsd-00025-0029 21:18:10.258296 [ client_ws_0009 ] WRN  Missing JSON property [DisableCopy]| wsd/Storage.cpp:353
    kit-00071-10443 21:18:10.946996 [ lok_handler ] ERR  Failed to load: file:///user/docs/71/NewSpreadsheet.ods, error: loadComponentFromURL returned an empty reference| kit/Kit.cpp:1149
    kit-00071-10443 21:18:10.947193 [ lok_handler ] ERR  Failed to get LoKitDocument instance.| kit/ChildSession.cpp:334
    wsd-00025-0029 21:18:10.977053 [ client_ws_0009 ] WRN  SocketProcessor [client_ws_0009]: Connection closed.| common/IoUtil.cpp:100

Here is my Virtual Host:

<VirtualHost *:443>
        ErrorLog /var/log/httpd/
    RewriteEngine on
    # Some rewrite rules in this file were disabled on your HTTPS site,
    # because they have the potential to create redirection loops.
    # RewriteCond %{SERVER_NAME}
    # RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,QSA,R=permanent]
    # SSL configuration, you may want to take the easy route instead and use Lets Encrypt!
      SSLEngine on
      SSLCertificateFile /etc/letsencrypt/live/
      SSLCertificateKeyFile /etc/letsencrypt/live/
      Include /etc/letsencrypt/options-ssl-apache.conf
      SSLCertificateChainFile /etc/letsencrypt/live/
      SSLHonorCipherOrder     on

      # Encoded slashes need to be allowed
      AllowEncodedSlashes NoDecode

      # Container uses a unique non-signed certificate
      SSLProxyEngine On
      SSLProxyVerify None
      SSLProxyCheckPeerCN Off
      SSLProxyCheckPeerName Off

      # keep the host
      ProxyPreserveHost On

      # static html, js, images, etc. served from loolwsd
      # loleaflet is the client part of LibreOffice Online
      ProxyPass           /loleaflet retry=0
      ProxyPassReverse    /loleaflet

      # WOPI discovery URL
      ProxyPass           /hosting/discovery retry=0
      ProxyPassReverse    /hosting/discovery

      # Main websocket
      ProxyPassMatch "/lool/(.*)/ws$" wss://$1/ws nocanon

      # Admin Console websocket
      ProxyPass   /lool/adminws wss://

      # Download as, Fullscreen presentation and Image upload operations
      ProxyPass           /lool
      ProxyPassReverse    /lool

My Server:

OS: CentOS 7
Server version: Apache/2.4.6 (CentOS)
Server built: Nov 14 2016 18:04:44

I’m also wondering about this. Have the same error.


I changed absolutely nothing but after a server restart the next day it worked. Sometimes it works, sometimes not. I have no idea why. Sometimes collabora shows an error message, but i can close the message and collabora work perfectly. I think it has something to do with the firewall, but I’m not sure.

Collabora Office ist a pita. Extremely unreliable.
Don’t use it.
It’s a demo version for a maximum of ten that is ‘10’ users.
They want to sell you the hosted version.

1 Like

For some reason, the steps I wrote up here fixed this problem for me (after updating the Docker image earlier today).