Collabora error Share Not found

When ever I try to open a document I get an error:

“Failed to read document from storage”

I think this is just a generic error, so i looked at logs:

[richdocuments] Error: OCP\Share\Exceptions\ShareNotFound: There was an error retrieving the share. Maybe the link is wrong, it was unshared, or it was deleted. at <>

  1. /var/www/public_html/apps/richdocuments/lib/Controller/WopiController.php line 650
  2. /var/www/public_html/apps/richdocuments/lib/Controller/WopiController.php line 144
    OCA\Richdocuments\Controller\WopiController->getFileForWopiToken(OCA\Richdocuments\Db\Wopi {id: 3147})
  3. /var/www/public_html/lib/private/AppFramework/Http/Dispatcher.php line 170
    OCA\Richdocuments\Controller\WopiController->checkFileInfo(“655562”, “HpWqQ1LLuPRHvBHMNii9rJ43WIQHrYSy”)
  4. /var/www/public_html/lib/private/AppFramework/Http/Dispatcher.php line 99
    OC\AppFramework\Http\Dispatcher->executeController(OCA\Richdocument … {}, “checkFileInfo”)
  5. /var/www/public_html/lib/private/AppFramework/App.php line 125
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\Richdocument … {}, “checkFileInfo”)
  6. /var/www/public_html/lib/private/AppFramework/Routing/RouteActionHandler.php line 47
    OC\AppFramework\App::main(“OCA\Richdocume … r”, “checkFileInfo”, OC\AppFramework\ … {}, {fileId: "655562 … "})
  7. <>
    OC\AppFramework\Routing\RouteActionHandler->__invoke({fileId: "655562 … "})
  8. /var/www/public_html/lib/private/Route/Router.php line 299
    call_user_func(OC\AppFramework\ … {}, {fileId: "655562 … "})
  9. /var/www/public_html/lib/base.php line 1008
    OC\Route\Router->match("/apps/richdocum … k")
  10. /var/www/public_html/index.php line 38

GET /index.php/apps/richdocuments/wopi/files/655562_ocpnjhucqqnk?access_token=HpWqQ1LLuPRHvBHMNii9rJ43WIQHrYSy&access_token_ttl=0
from at 2020-07-24T11:00:40+00:00

Im running version 18.0.7 of nextcloud, php 7.2
Collabora runs from latest container Image on docker.
Web server is apache 2.4.29
Server is running Ubuntu 18
Both applcications have their own subdomain with a valid SSL cert generated by lets encrypt.

I suspect there is something wrong with the database schema, I have been running this instance since v 9 of nextcloud and I was always able to run collabora alongside Nextcloud.

I think maybe the paths sotred on the DB to link files to Collabora are broken. But this is just a wild guess.

I have tried creating a new user and tried to create and edit new documents and the same error persists.

I could use some help in resolving this issue, I have looked on the forums and google and could not find something similar to my problem, so its probably a good idea to start start thread like this for the future.

Thank you in advance, Pablo.