Collabora "connecting" delay for 20 seconds

I’ve setup two VM’s - one running Nextcloud 9.0.52 and the other running the docker image for Collabora Online. I’ve set it up as per the online documentation. Both servers have real SSL certs installed.

Everything works perfectly and I was super happy to have Collabora fire up first time and I’m able to edit documents and spreadsheets and the like.

What I’m curious about is when I launch a document. Collabora fires up and I get a “connecting” spinner for about 20 to 25 seconds before the document comes up.

I’ve been trying to debug this - both VM’s and the docker session are all low CPU load and I’ve done a whole bunch of tcpdumps to see if something is trying to connect to something which isn’t responding.

My initial suspicion was a DNS lookup or similar causing the delay however nothing shows up in the wireshark traces. There are no errors anywhere I can see.

Is this normal behaviour? Does everyone else have the same 20 odd second delay that I have?

cheers, wizdude

1 Like

+1

I run it not in a VM. Collabora runs successful on my ubuntu14.04. But I have also this 20 seconds delay. Somtimes a document are not loaded and the spinner turns and turns.

Yes, same thing here, I will try to build collabora separately without using docker image.

1 Like

Did anyone manage to work anything out with this? I was watching a recent video where they did Nextcloud and the docker image on a single VM and there was virtually no delay.

I’m very keen to try and work out why this behaviour is occurring with the test environments I have setup.

cheers, wizdude.

Sorry for the delay, I can’t really find time to build it. spent a coupe of hours last night. Finished building loolwsd. Almost finished. I will try to finish it tonight.

If you’re interested and have some free time you can build it yourself and test it.

Thanks

Same issue here, i wonder if have the correct setup, i have a reverse proxy config on my nextcloud pointing to the collabora docker, its office.domain.ext in the connector app i have set office.domain.ext as url.

it works. but opening files takes indeed, 20 to 30 seconds…

regards,
Gert-Jan Slot

Same Problem. Debian 8, Kernel 4.6, PHP 5.6.24.

Everything works ok with Docker Image, opening files 20 to 30 seconds.

Okay good and bad news. I compiled it and sort-of made it work.
But I get this error now

Does any one know what WOPI I need, and are there any information how to set it up?
It pretty much loads instantaneously now to the point where it’s closing connection. Help me guys

wsd-31909-13 00:00:08.274437 [ client_ws_0001 ] No acceptable WOPI hosts found matching the target host [mycloud.address.com] in config.
mkit-31952-00 00:00:08.255557 [ loolkit ] Process started.


Okay I tweaked it a little more and here’s what I get:
Basically for some reason it’s saying WOPI host is not on the same host as the WOPI client, even though it is (I’m not sure how this whole thing is working).

wsd-09855-12 00:01:03.615237 [ client_ws_0002 ] WOPI host is not on the same host as the WOPI client: “my host ip”. Connection is not allowed.
wsd-09855-12 00:01:03.615358 [ client_ws_0002 ] No acceptable WOPI hosts found matching the target host [cloud.myhost.com] in config.

Nevermind, got everything working from the information at next thread: I edited my server info in loolwsd.xml

So guys, best way is to compile everything and it should be working. Sources are here: https://github.com/libreoffice/online

that docker image sux and 100% not for production

so is the 20 sec delay solved?!?

Yes, when using built office(and not the docker) there is no delay, also, no reason to use reverse proxy, 2nd domain name(and ssl for it). No reason to run docker and take extra resources. As I’m running both NC and OC this built libreoffice works for both.

Why don’t we have both instructions, for Docker and manual installation? Without instructions it took me 3-4 times longer to figure things out.

1 Like

We could provide both but the idea was that the docker image is a lot easier, not only with initial installation but also upgrades.

Could you point me to the guide/readme you used? I or we can attempt to script it so its automated.

The resources that I used are here:

https://github.com/libreoffice/online

It says what to install there:

  1. loolwsd (LibreOffice On-Line WebSocket) – manual of the installation is there, but it will require some time and it’s not going to work “right out of the box”, I spent good couple of hours figuring out what’s what.

  2. loleaflet (Leaflet platform for LibreOffice On-Line) – again, manual of the installation is there.

It gave me a couple of warnings about some png and css file (which were not crucial) but I just took them from docker image that had them =)

P.S. I probably can describe the steps I used when installing it on Ubuntu 14.04 if you need it more detailed

Yeah that was my biggest fear… Haha I’ve tried that like 4 times past year… My temper on that project broke some desktop items…

I’ll just give it another go, could you tell me more about the png and css files and taking them from the docker?

I’ll keep you posted.

ps: we could create a gist and work on it together to provide an alternative solution to the docker?

Thanks!

It would be good to have an automated script to run the build process. I have now tried it 3 times and I am getting errors during the LibreOffice build, I can’t even get to the other 2 items.

/root/core/external/libetonyek/ExternalPackage_libetonyek.mk:19: *** file /root/core/workdir/UnpackedTarball/libetonyek/src/lib/.libs/libetonyek-0.1-lo.so.1.0.6 does not exist in the tarball.  Stop.
make[1]: *** Waiting for unfinished jobs....
Makefile:261: recipe for target 'build' failed
make: [build] Error 2 (ignored)

Running Debian 8.5 64-bit headless

Be sure you follow instructions from here
I’m also at libreoffice compile step, but I do this on a raspberry Pi2 and…boy…it takes a looooong time :slight_smile:

I have followed those steps:

  1. Install dependencies
  2. clone git repository of core
  3. run autogen
  4. run make

and still hit the same issue. I tried and search for the libetonyek-0.1-lo.so.1.0.6 file in any of the packages I might not have installed for Debian 8.5, but can’t find any package that has that file.

Try build libetonyek also from git source, but before that install all build dependencies :
> sudo apt-get build-dep libreoffice