Collabora CODE installation on DEBIAN 9 apt-update doesn't work

Hello all,

I encounter a problem during the configuration of CODE. I follow the tutorial accessible on the collaboraoffice website.

I want to install the CODE server on my own Debian 9 instance. I run the two following lines

apt-key adv --keyserver --recv-keys 0C54D189F4BA284D


echo ‘deb ./’ >> /etc/apt/sources.list

but when i run apt-get update && apt-get install loolwsd code-brand i get the following message :

The repository does not have a Release file.

You can found in attachment a screenshot of the full log.

If someone can help me it would be really appreciated :slight_smile:

Thanks in advance!



I tried the commands above and I did not get error message. If you go to you can see that the repository has Release file.

Thanks to you for your answer.
It seems the problem come with my Debian 9 installation. I think I have a problem with all HTTPS package link. I’ve tried to reinstall apt-transport-https but it doesn’t change anything.

I know now it doesn’t come from Collabora CODE but if someone has an idea, all suggestion would be appreciated :slight_smile:

Are you using an apt proxy? In my case I had an apt proxy set up. You can either disable your proxy for that machine or bypass it for that one url (which is better).

To bypass the proxy (assuming you have one), go to /etc/apt/apt.conf. In here if you have a proxy line, add a new line under it that looks like this:

Acquire::http::Proxy { DIRECT;

It is also possible that your proxy config can be in a file in the apt.conf.d directory. If so, add the line there. It will likely be in /etc/apt/apt.conf if you set it up that way during install though. For me this cleared the issue right up. I guess https urls have issues making it pass the proxy. Not sure how to configure it to pull one through the apt cacher proxy, though I assume it can be done with a little config work.