Collabora and Nextcloud on the same server

I tried to install Collabora server and the Nextcloud server, each of it has its own server, FQDN, etc.
It works. Now I am wondering and trying to make it work on one server, one FQDN, etc. It works partly. From LAN its OK, from Internet its not working. I have enabled ports 443 and 9980. Any ideas ? Is it possible to run these two SW on the same server ?

yes.

this playbook may give you a reference installation (on a test server) to check the config. only working for nginx. apache is still work in progress.

Thanks, but I was unsuccesful to get it worked. I crashed on certboot. Some kind of error on CentOS.
Anyway, I succesfully runs nextcloud and Collabora server on the same FQDN, but I had to enable port 9980 on firewall. I am not sure how much is it danger and unsecure. I tried to setup a apache reverse proxy, but no luck with that.

yes. centos is an error. :wink:

forgot to mention, that the “reloaded” version of the playbook is not centos ready yet.

https or http? public internet or private intranet?

I used the same cert for both of them from Let’s Encrypt, so yes, https and public internet.
Normally, for Nextcloud I opened only port 443, but here I have to open 9980 too.

i can’t confirm this. i only needed to open a separate port for only office.

Maybe you have dive a little bit deeper into ip tables and there is only a rule missing that blocks internal traffik to the container. or it’s selinux related.

are you using the containered version?

I imagine when apache reverse proxy will works, I can close port 9980. When I split SW to two separate servers with two different FQDN, then it works without port 9980. I guess it is because in nextcloud I have patch to collabora https://FQDN:9980, without a port specify it not working, perhaps because on https is running nextcloud.

No, i am on physical server.

why fqdn? why not localhost:9980? see below:

the docker version is using the container name as fqdn:

btw: you could configure iptables to only allow ip 127.0.0.1 on port 9980. that is to check if the client is talking to this port.

No, I mean URL in nextcloud settings, in proxy I have correct localhost:9980

Yes. But in my setup it’s https://{{ nexcloud_fqdn}}:443/ because nginx acts like a reverse proxy here. So I don’t need to open 9980.

I tried your suggestion, but no luck. Nexcloud says can’t connect to a server without 9980 or with 443. Perhaps my apache reverse proxy doing something wrong. Although https://FQDN/hosting/discovery works like a charm.

Hello, any luck with this issue? I have the same problem :(.

Please check if the reverse proxy is set up properly according to Proxy settings — SDK https://gitlab.com/pages/sphinx documentation

I realized that my setup was missing a line on …/hosting/capabilities and after I fixed that it worked like a charm.