Collabora allow-list for WOPI requests | broken UI

Hi Everyone :wave:

I’m working through setting up NextCloud for a friend, and I am getting a weird issue where the Allow list for WOPI requests field blanks itself on confirmation (By pressing ENTER or clicking the arrow adjacent to the field)

As a result, I’m not able to set the Allow List properly or get rid of the WOPI Allow List warning.

  1. Is this a known bug?
  2. Is there a way to set the allow list programmatically or via occ? The only thing I found in occ was related to regenerating blank templates and converting something to bigInt.

NextCloud: docker container.
Collabora: Official COOL container.
Reverse Proxy: SWAG docker container (Nginx-based)

As far as I can tell, there are no issues with Collabora being able to communicate with Nextcloud. I also have the proxy in Nextcloud’s trusted_proxies.

I would also like to test the claim that “Without this setting users may download restricted files via WOPI requests to the Nextcloud server”. Is there a sample request that I can reference? It’s my first time dealing with WOPI

1 Like

hi @TheACS welcome to the forum :handshake:

as you you are using custom linuxserver image I would recommend you reach out to Support and Nextcloud docs.

You will find references to how wopi works and what could go wrong in Collabora integration guide

@wwe Thank you :blush:

I’ll check out the linuxserver forums.

In the meantime, Is there a way to actually check if the files are world-accessible through a NextCloud WOPI request?

I read your integration guide before posting, but it didn’t seem to have the information I’m after.

From your reply, I can assume there’s no way to set the Allow List other than the NextCloud UI, correct?

I appreciate the help :pray:

you can use occ occ config:app:get richdocuments wopi_allowlist and occ config:app:set richdocuments wopi_allowlist

Excellent! I’ll try that. Thank you for your support.

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.