Code integrity check failed - once again

Hi there,

I know it’s an annoying issue and there are lots of thread about it but still I can’t get it fixed.
I receive the following message:

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix


  • news
      • vendor/ezyang/htmlpurifier/maintenance/.htaccess

Raw output

[news] => Array
[vendor/ezyang/htmlpurifier/maintenance/.htaccess] => Array
[expected] => 4d51270ac56b1600199cd52c4f0fc34171bb306db59761863c87978049b771a053ebb80c8dda03b4d98bf5e43361ec0e1e1d2ad4b01fc315fb809b40acd23843
[current] =>




According to all the other thread about this issue it’s just necessary to replace the existing .htaccess file with the one from the archive. I did that but the problem still occurs.


As you can see the file is available and even the owner is set to the right value. Do you guys have any clue what I can do about it?

Thanks a lot!

Nextcloud version (eg, 12.0.2): 14.0.1
Operating system and version (eg, Ubuntu 17.04): Ubuntu 18.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4
PHP version (eg, 7.1): 7.2


I also have this same error upon successfully upgrading from 13.0.6 to 14.0.1


I’m running nginx so .htaccess files are irrelevant and NOT a way to set security

Same problem here!

Same here - on different nextclouds.

Same here, upgrading from 13.0.6 to 14.0.1, “Some files have not passed the integrity check.”

NEED HELP :frowning:

Should be this problem:

Just download the .htaccess file or create one in


with the content

Deny from all

Then run the test again and the error should be away.

Worked for me.


Unfortunately it didnt’ work for me. But thanks a lot anyway!
Even if I disable and remove the news app, I still receive the error message.

Had the same issue when updateing from 13.0.6 to 14.0.1.
The problems are caused by the News app (in my case).
Here are the steps to get rid of this error message:

  1. Disable and remove the News app
  2. Rescan for file integrity (there is a link for rescanning next to the error message itself).
  3. The error should be gone.
  4. Now go ahead and re-download and enable the News app from the app store.

Note that the app’s settings (e.g. all configured RSS subscriptions) will not be lost by removing and downloading the news app afterwards.

Now it’s fixed. I just downloaded Nextcloud again and replaced the existing .htaccess with the downloaded one (even if I did that before). Regarding the news app: I disabled it. I will give it a try later this year :wink: