Cloudflare Proxy / Cloudflare Tunnel


When I connect to nextcloud via Cloudflare Proxy or Cloudflare Tunnel, I can log in and see the dashboard, but I can’t click on the icons.

(Cloudflare Proxy or Cloudflare Tunnel) -> nginy (Reverse Proxy)->Apache (nextcloud)
                Public domain                port:443  Local domain  port:4444 HTTPS

When I call nextcloud from the local domain, everything works. What also works is when I turn off cloudflare proxy my IP is visible or with cloudflare tunnel I have to open ports on router / firewall.

Other services like wordpress work via cloudflare proxy or cloudflare tunnel.

Does no one have any idea what the problem could be?

I solved this??

The same problem

I install in docker Nexcloud and i add a docker for tunnel Cloudlfare all ok, but , the same problem wit your explain.

Is problem the cloudflare tunnel???

Hi People! :vulcan_salute:

I have the same problem, im on oracle cloud ampere a1 cpu (AARCH) Ubuntu 22.04
mainline nginx server… nextcloud is the latest stable, and 25.0.2 RC2
the configuration is from nextcloud documentation
But i tryed with snap, and nginx reverse proxy, and with cloudflared tunnel… and with docker container… and cloudflared tunnel…
bassically behave all the same… but snap is the least configurable, couse cant modify the server settings, for example cant hide the index.php …

I created a video about this bug maybe some dev can know what to do with this situation… maybe… blizzz or rakekniven ? :pray:

And btw at the end of the video i talk about some outher sharing bugs, which is present on demo2 nextcloud (the free trial instance) as well…

BTW This whole forum is dead? Couse i dont see any respond from Admins/devs …

Apparently this seems to be connected with cloudflare/tunnel.

You are on the nextcloud community forum. Where everone helps everbody. No guarantee that any devs are going to chime in


I found this: Fresh Nextcloud Install. Login page with background and logo but no login box? - #19 by ehinola_kingsley


Thank you! Thats helped a lot! :pray: