Client synchronization hangs after a simple data operation

I am using the desktop client (currently 3.11, but I have also tried older ones) under Linux Mint 21.2 Cinnamon. My provider is using version 27.1.5 as server.

For two days now, data synchronization has stopped working. At that time I was using version 3.4.2, which was offered in the Linux Mint repository.

After I had created a directory on my computer and copied some data into it, the client started synchronizing as expected, but nothing worked after that. The icon remained blue, the client could no longer be closed and the client window could not be opened either. I then terminated the process and restarted the client, but the result has remained the same ever since. Even the installation of version 3.11 via Flatpak and the complete uninstallation and reinstallation of the client did not produce any results.

Is there a general problem or is there anything I can do to get the desktop client working again?

Any help would be greatly appreciated.


1 Like

Hey I thought I had a similar problem. Moved some files on the client and then sync seemed to be completely stuck. I haven’t had the issue with closing the client though.

Anyway, a useful thing I just discovered is that the settings window has slightly more detail on what the sync is doing. In my case there are a very large number of files that it’s working through to check for changes.

From the main client window it just shows Syncing with 0 seconds left, but the settings window showed me that it was not stuck, just taking a really long time.

Anyway, that may or may not be helpful for your situation.

Good luck!

Thanks for your reply. Unfortunately I’m not able to access the settings window. The right click popup appears but when I click settings nothing happens.

I also thought that the problem may be caused by the huge ammount of files I have. Therefore I let the system work for about two days but that changed nothing.

In the meantime, after restarting my computer the task bar icon has changed. Now it is no longer the blue synchronization icon of Nextcloud but a small screen with a red circle in the middle. But I don’t think that means anything, because the hover text still says that synchronization is currently taking place.

After restarting the client again, I noticed something. Apparently the client checks the contents of the directories, because my external hard disk, on which some of the data to be backed up is located, suddenly starts to work.

I can also see in the system monitoring that the Nextcloud process uses a relatively large amount of system resources (about 12 % CPU use permanently).

So it seems that the client is active, but I can’t see any changes in the history on the Nextcloud server.

Maybe this information helps to find a solution.

Another finding: When I restart the client, it initially synchronizes some files, but then stops. I also found a number of entries like this in the log files:

2023-12-23 15:57:28:358 [ warning /run/build/nextcloud-client/src/libsync/owncloudpropagator.cpp:1251 ]: Useless task found for file “Path/To/Directory/File.ext” instruction CSyncEnums::CSYNC_INSTRUCTION_NEW

Maybe the Synchronisation stopps because of these entries. But I can’t exclude these folders and files because I can’t open the exclude window. As far as I read somewhere there is no way to edit the exclude list manually, right?

Is it possible that the error occurs because a hidden directory is to be synchronized?

I have managed to open the client window. Immediately after I restarted the client and the icon appeared, it was possible to open the window. The client then started synchronizing and then the window froze and I couldn’t do anything.

I have been strugling with the same problem for about a week now on linux mint 21.2
I have no idea what causes this, because at the time I found the problem, there were no principal changes on my server. Only the client was updated.
I tried older clients, but result is the same.
Then I tried from other PCs (also mint 21.2 and lmde6), no changes.
You can, if the client machine is clean, make full syncronization without any problem. But when you makes changes in the local folder (I used exiftool for renaming files), my nextcloud client hangs totally.
When this happenes I see no errors in logs. And Nginx access.log shows that the client connects to the server and tries to access files, but very slow.
Maybe the problem is caused by linux mint?

This is not good news :slightly_frowning_face:, but thanks for the feedback.

I haven’t given up completely yet. If I find a solution, I’ll let you know.

I started Nextcloud AppImage file from the terminal and saw:

nextcloud.gui.application: Migrating old config from "/home/user/.local/share/Nextcloud" to "/home/user/.config/Nextcloud"
nextcloud.gui.application: Failed to move the old config directory to its new location ( "/home/user/.local/share/Nextcloud" to "/home/user/.config/Nextcloud" )
nextcloud.gui.application: Will move the individual files ("Nextcloud_sync.log", "Nextcloud_sync.log.1")
nextcloud.gui.application: Fallback move of  "Nextcloud_sync.log" also failed
nextcloud.gui.application: Fallback move of  "Nextcloud_sync.log.1" also failed

Then I thought why not to move the Nextcloud directory manually from /home/user/.local/share/ to /home/user/.config/

As far as I understand in the old directory there was no current database for the client, so I had to wait several hours while client have been synchronizing again (with the local copy of my Nextcloud folder, not from the very beginning).

But since then everything works fine for me (after restarting from the terminal warnings appeared again, but this didn’t affected).

I am not sure if it is a solution, but hope so.

1 Like

Thanks for your reply.

Maybe I was too impatient to wait because I have around approx. 600 GB of files and this may take a looooong while to scan :grinning:. So I’ll try it again tomorrow and let it run as long as it takes.

I had 1,2 Tb to rescan. It was faster then I thought.

OK, everything seems to be working again now. However, I had to delete all traces of Nextcloud and reinstall it. The system then carried out a synchronization, which also restored a number of files that I had already deleted or changed on my local computer. But I can live with that.

It’s a little annoying that the icon in the taskbar doesn’t change. I can’t see at a glance what the status of Nextcloud is at the moment. But I’ll probably have to open a separate thread for that.

How does the icon look like now?

Maybe the problem is in flatpack version which icon is grey instead of green?


This icon is displayed. In the old client version, this icon always appeared during initialization and then changed to the standard icon.

But this morning I had other problems. The autostart function did not work. I then entered the client manually in the autostart list. The client then started, but did not connect to the server. I may have used the wrong start command, but this should actually be the same command that is stored in the menu item. When I quit Nextcloud again and restart it, the server connection is established.

But at least the synchronization seems to work now :wink:.