Client connection closed: SSL_write() failed (SSL:)

Nextcloud version: 12.0.4
Operating system and version : Gentoo Linux x64
nginx version: 1.12.2
PHP version: 7.1

Hello,
I have a big problem with my nextcloud installation. I try to sync my music collection with my laptop.
This are ~25GB. But every time the nextcloud client fails (sometimes after 200MB, 400MB or immediately).

The message in the client:
<filename 1>: Connection closed
<filename 2>: Operation abborted
<filename 3>. Operation abborted

Here is the nginx-error.log:

2018/01/21 14:12:45 [info] 24598#24598: *1320 SSL_write() failed (SSL:) (104: Connection reset by peer) while sending to client, client: 192.168.0.1, server: nextcloud.domain, request: “GET /remote.php/dav/files/siggi/Musik/Die%20Apokalyptischen%20Reiter/Tief/10%20Die%20Apokalyptischen%20Reiter%20-%20Die%20Welt%20ist%20tief.mp3 HTTP/1.1”, upstream: “fastcgi://unix:/run/php-fpm.socket:”, host: "nextcloud.domain"
2018/01/21 14:12:45 [info] 24598#24598: *1333 epoll_wait() reported that client prematurely closed connection, so upstream connection is closed too (104: Connection reset by peer) while sending to client, client: 192.168.0.1, server: nextcloud.domain, request: “GET /remote.php/dav/files/siggi/Musik/Die%20Apokalyptischen%20Reiter/Tief/11%20Die%20Apokalyptischen%20Reiter%20-%20So%20fern.mp3 HTTP/1.1”, upstream: “fastcgi://unix:/run/php-fpm.socket:”, host: "nextcloud.domain"
2018/01/21 14:12:45 [info] 24598#24598: *1345 epoll_wait() reported that client prematurely closed connection, so upstream connection is closed too while sending request to upstream, client: 192.168.0.1, server: nextcloud.domain, request: “GET /remote.php/dav/files/siggi/Musik/Die%20Apokalyptischen%20Reiter/Tief/folder.jpg HTTP/1.1”, upstream: “fastcgi://unix:/run/php-fpm.socket:”, host: “nextcloud.domain”

Here are my nginx config files:

nginx.conf:

user nginx nginx;
worker_processes auto;

error_log /var/log/nginx/error_log info;

events {
    worker_connections 1024;
    use epoll;
}

http {
    upstream php-handler {
            server unix:/run/php-fpm.socket;
    }

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    log_format main
            '$http_x_forwarded_for - $remote_user [$time_local] '
            '"$request" $status $bytes_sent '
            '"$http_referer" "$http_user_agent" '
            '"$gzip_ratio"';

    client_header_timeout 10m;
    client_body_timeout 10m;
    send_timeout 10m;

    connection_pool_size 256;
    client_header_buffer_size 25600k;
    large_client_header_buffers 4 2k;
    request_pool_size 4k;

    gzip off;

    output_buffers 1 32k;
    postpone_output 1460;

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;

    keepalive_timeout 75 20;

    ignore_invalid_headers on;

    include /etc/nginx/vhosts/*.conf;
}

vhosts/nextcloud.domain.conf:

server {
    listen *:80;
    server_name nextcloud.domain;
    return 301 https://$server_name$request_uri;
}

#HTTPS-Server
server {
    #listen *:443 ssl;
    listen 443 ssl http2;
    listen [::]:443 ssl http2;
    server_name nextcloud.domain;

    ssl_certificate /etc/letsencrypt/live/domain.de/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/domain.de/privkey.pem; # managed by Certbot

    ssl_session_cache shared:SSL:10m;
    ssl_session_timeout 5m;

    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;

    # Path to the root of your installation
    root /var/www/nextcloud.domain/htdocs/nextcloud/;

    location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
    }

    location = /.well-known/carddav {
            return 301 $scheme://$host/remote.php/dav;
    }
    location = /.well-known/caldav {
            return 301 $scheme://$host/remote.php/dav;
    }

    # set max upload size
    client_max_body_size 2G;
    fastcgi_buffers 256 4K;

    # Enable gzip but do not remove ETag headers
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/vnd.ms-fontobject application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/bmp image/svg+xml image/x-icon text/cache-manifest text/css text/plain text/vcard text/vnd.rim.location.xloc text/vtt text/x-component text/x-cross-domain-policy;

    # Uncomment if your server is build with the ngx_pagespeed module
    # This module is currently not supported.
    #pagespeed off;

    location / {
            rewrite ^ /index.php$uri;
    }

    location ~ ^/(?:build|tests|config|lib|3rdparty|templates|data)/ {
            deny all;
    }
    location ~ ^/(?:\.|autotest|occ|issue|indie|db_|console) {
            deny all;
    }

    location ~ ^/(?:index|remote|public|cron|core/ajax/update|status|ocs/v[12]|updater/.+|ocs-provider/.+|core/templates/40[34])\.php(?:$|/) {
            fastcgi_split_path_info ^(.+\.php)(/.*)$;
            include fastcgi_params;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_path_info;
            fastcgi_param HTTPS on;
            #Avoid sending the security headers twice
            fastcgi_param modHeadersAvailable true;
            fastcgi_param front_controller_active true;
            fastcgi_pass php-handler;
            fastcgi_intercept_errors on;
            fastcgi_request_buffering off;
            fastcgi_buffering off;
    }

    location ~ ^/(?:updater|ocs-provider)(?:$|/) {
            try_files $uri/ =404;
            index index.php;
    }

    # Adding the cache control header for js and css files
    # Make sure it is BELOW the PHP block
    location ~* \.(?:css|js|woff|svg|gif)$ {
            try_files $uri /index.php$uri$is_args$args;
            add_header Cache-Control "public, max-age=15778463";
            add_header X-Content-Type-Options nosniff;
            add_header X-XSS-Protection "1; mode=block";
            add_header X-Robots-Tag none;
            add_header X-Download-Options noopen;
            add_header X-Permitted-Cross-Domain-Policies none;
            # Optional: Don't log access to assets
            access_log off;
    }

    location ~* \.(?:png|html|ttf|ico|jpg|jpeg)$ {
            try_files $uri /index.php$uri$is_args$args;
            # Optional: Don't log access to other assets
            access_log off;
    }

}

I hope somebody can help me with this problem.

dsiggi