CLI update but http not updated without apache restarted

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 2.6.3 to 2.7.0
Operating system and version (eg, Ubuntu 20.04): debian
Apache or nginx version (eg, Apache 2.4.25): apache
PHP version (eg, 7.4): 8.1

The issue you are facing:

After upgrade via CLI : web access stay disable and i don’t find any way to reset file cache.

On CLI :

$ php8.1 -d apc.enable=1 -d apc.enable_cli=1 /home/www/sites/ --version
Nextcloud 27.0.0
$ php8.1 -d apc.enable=1 -d apc.enable_cli=1 /home/www/sites/ upgrade
Nextcloud is already latest version
$ php8.1 -d apc.enable=1 -d apc.enable_cli=1 /home/www/sites/ maintenance:mode --off
Maintenance mode already disabled

But on web : on

Is this the first time you’ve seen this error? (N):

Steps to replicate it:

  1. Upgrade via CLI
  2. maintenance mode off via CLI
  3. Try to log

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'debug' => false,
  'instanceid' => 'XXXXXXXXXX',
  'passwordsalt' => 'XXXXXXXXXXXXXXXXXXXXXX',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/home/www/sites/',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'example_nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'example_nextcloud',
  'installed' => true,
  'maintenance' => false,
  'loglevel' => 2,
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'default_phone_region' => 'FR',
  'htaccess.RewriteBase' => '/',
  'theme' => '',
  'mail_smtpstreamoptions' => 
  array (
    'ssl' => 
    array (
      'allow_self_signed' => true,
      'verify_peer' => false,
      'verify_peer_name' => false,
  'mail_sendmailmode' => 'smtp',
  'mail_smtpmode' => 'smtp',
  'mail_smtphost' => 'localhost',
  'mail_smtpport' => 25,
  'mail_smtpsecure' => '',
  'mail_from_address' => 'contact',
  'mail_domain' => '',
  'mail_smtpauth' => false,
  'mail_smtpname' => '',
  'mail_smtppassword' => '',

Is there a way to avoid such situation ? Maybe a ?