CIFS / Storage not available

if I map an external Storage (CIF share from an w2k12 server or a NAS) I will see the green dot at the backend. When I access on the folder I got an popup “storage not available”.

  • nextcloud10.0 on debian, smbclient is installed.

Has anybody CIFS shares successfully mapped?
Any idears or tips?

Thx a lot.

Exception: {“Exception”:“OCP\Files\StorageNotAvailableException”,“Message”:“Connection unsuccessful”,“Code”:0,“Trace”:"#0 /var/www/html/apps/files_external/lib/Lib/Storage/SMB.php(171): OCA\Files_External\Lib\Storage\SMB->getFileInfo(’’)\n#1 /var/www/html/lib/private/Files/Storage/Common.php(437): OCA\Files_External\Lib\Storage\SMB->stat(’’)\n#2 /var/www/html/apps/files_external/lib/Lib/Storage/SMB.php(438): OC\Files\Storage\Common->test()\n#3 /var/www/html/apps/files_external/lib/config.php(233): OCA\Files_External\Lib\Storage\SMB->test(false, false)\n#4 /var/www/html/apps/files_external/lib/Controller/StoragesController.php(257): OC_Mount_Config::getBackendStatus(’\\OCA\\Files_Exte…’, Array, false, false)\n#5 /var/www/html/apps/files_external/lib/Controller/UserGlobalStoragesController.php(121): OCA\Files_External\Controller\StoragesController->updateStorageStatus(Object(OCA\Files_External\Lib\StorageConfig), false)\n#6 [internal function]: OCA\Files_External\Controller\UserGlobalStoragesController->show(2, false)\n#7 /var/www/html/lib/private/AppFramework/Http/Dispatcher.php(160): call_user_func_array(Array, Array)\n#8 /var/www/html/lib/private/AppFramework/Http/Dispatcher.php(90): OC\AppFramework\Http\Dispatcher->executeController(Object(OCA\Files_External\Controller\UserGlobalStoragesController), ‘show’)\n#9 /var/www/html/lib/private/AppFramework/App.php(111): OC\AppFramework\Http\Dispatcher->dispatch(Object(OCA\Files_External\Controller\UserGlobalStoragesController), ‘show’)\n#10 /var/www/html/lib/private/AppFramework/Routing/RouteActionHandler.php(47): OC\AppFramework\App::main(‘UserGlobalStora…’, ‘show’, Object(OC\AppFramework\DependencyInjection\DIContainer), Array)\n#11 [internal function]: OC\AppFramework\Routing\RouteActionHandler->__invoke(Array)\n#12 /var/www/html/lib/private/Route/Router.php(293): call_user_func(Object(OC\AppFramework\Routing\RouteActionHandler), Array)\n#13 /var/www/html/lib/base.php(967): OC\Route\Router->match(’/apps/files_ext…’)\n#14 /var/www/html/index.php(48): OC::handleRequest()\n#15 {main}",“File”:"/var/www/html/apps/files_external/lib/Lib/Storage/SMB.php",“Line”:133}

Hi Schorschie,
please have a look at: Mount your NAS to nextcloud
We mount a share to users data-directory in nextcloud ~ 650 GB of 1.5 TB in use.
Do not forget to set ‘filesystem_check_changes’ => 1, in config.php and run occ:filescan at least for the dedicated user.
Cheers, Carsten

Hi Carsten,
thanks for answer. Your tip, and your website, did´t help due this issue.

Any other idears? Is it an own-/nextcloud bug? Or are missing some requirements?
Why doesn´t work that, after is is “green” configured in the backend?
Cheers, Schorschie

There was a problem which is a bit similar:
It was solved but we don’t know how.

Hi Schorschie,

I’m having exactly the same issue.
Did you solve it ?


Hi, I didn’t find a solution.

One time i got a connection.

  • Share on w2k12 on C partition. (Not an extra partition, like E:)
  • At nextcloud backend I filled the IP of the server, the share AND an exist folder in the share. I know it sounds curios.

Actually I use FTP to a NAS, that works.

If you have some news to resolve it, please let us know… :slight_smile:


I have this issue fixed on my server.
My Nextcoud server is a CentOS with php55 installed.
(instructions on

As mentioned in , it is recomended to use libsmbclient-php. I assumed I had it, but it was the package for PHP5.4.

You have to build php5-libsmbclient for your distribution. Instructions on .

In my case the problem got solved.


I had the a similar issue getting it to connect to SBS 2011 shares. I had to add “” to my php.ini file to get it to work. This was with php 7.0.