This falls between installation/support. I have nextcloud up and running, but every reboot I have a problem because it’s really not correct. (Ubuntu bionic, essentially barebone install without docker, etc)
I have been running freshrss, which uses the default mysql socket. The server config for nextcloud also uses that socket. What ends up happening is that apparmor ends up locking one out on reboot - so I have to remove apparmor, and everything is great until reboot, when the cycle repeats.
I’d like to get the DB and nextcloud working on a different socket, but don’t understand the full process. When I change mariadb’s socket in the /etc/mysql/mariadb.conf.d/50-server… folder, the next reboot of mariadb fails with the following(shown via Journalctl), and nextcloud is inaccessible
“ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2 “No such file or directory”)”
Clearly mariadb is attempting to use the original socket, but I don’t know where else to make the socket changes. Can anyone help?