Changes to Calendar Events and Contacts are not saved. Any ideas?

Nextcloud version (eg, 20.0.5):
NextcloudPi version: v1.43.7
Operating system and version (eg, Ubuntu 20.04): Debian GNU/Linux 10. 5.10.63-v8+ (aarch64)
Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.38 (Debian)
PHP version (eg, 7.4): PHP 7.3.31-1~deb10u1

The issue I face:

I can create a calendar event or a contact over the web interface , it can also be deleted, but not changed (eg time, date, details). But it can be changed over CalDav/CardDav sync (eg my phone).
There are no errors in the log.
I tried different browsers and cleared my cache.
Somehow I think this two issues are related because they are very similar.

Calendar behavior:
When I try to change a event in the calendar and press save, the progress circle appears and goes on forever (tried it for hours) image
when I refresh the webpage the sidebar shows me that the event would not exist, but it is still present in the calendar image
but the changes I made wasn’t saved.

Contacts behavior:
When I try to change contact details with the browser I even can press ctrl. + S to save the changes. at the bottom of the contact it is also shown as saved. image
But when I refresh the page, the changes are gone.

Is this the first time you’ve seen this error? (Y/N):

No, its persistant since a while now, hoped that it will be fixed in upcoming server or app versions.

The output of your Nextcloud log in Admin > Logging:

There are no failures or errors in the log

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' =>
  array (
    0 => 'localhost',
    1 => '',
    2 => 'xxxxxxxxxxxxxxx',
    3 => 'xxxxxxxxxxxxxxxxxxxxxx',
    11 => 'xxxxxxxxxxxxxxxxxxxx',
    22 => 'nextcloudpi',
    '' => 'nextcloudpi',
    14 => 'nextcloudpi',
  'datadirectory' => '/media/data/ncdata',
  'dbtype' => 'mysql',
  'default_phone_region' => 'xx',
  'version' => '',
  'overwrite.cli.url' => 'https://nextcloudpi/',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx=',
  'installed' => true,
  'instanceid' => 'xxx',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
    'password' => 'xxxxxxxxxxxxxxxxxxxxxx',
  'tempdirectory' => '/media/data/ncdata/tmp',
  'mail_smtpmode' => 'sendmail',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'xxxxxxxxxxxxxxxx',
  'mail_domain' => 'xxxxxxxxxxxxxxxxxxxxxxxxxx',
  'preview_max_x' => '2048',
  'preview_max_y' => '2048',

The output of your Apache/nginx/system log in /var/log/____:

[Wed Nov 17 00:00:03.158272 2021] [mpm_event:notice] [pid 1507:tid 548551787904] AH00489: Apache/2.4.38 (Debian) OpenSSL/1.1.1d   configured -- resuming normal operations
[Wed Nov 17 00:00:03.158402 2021] [core:notice] [pid 1507:tid 548551787904] AH00094: Command line: '/usr/sbin/apache2'
[Wed Nov 17 00:05:15.034978 2021] [:error] [pid 22607:tid 548044517760] [client 39.84.xx.xx:54367] [client 39.84.xx.xx] ModSecurity: Warning. Match of "rx ^%{tx.allowed_request_content_typ$
[Wed Nov 17 06:12:37.797722 2021] [:error] [pid 22607:tid 547465716096] [client] [client] ModSecurity: Warning. Match of "rx ^%{tx.allowed_request_con$

Thanks for reporting,
Linked to github
as testing NC22.2.1 is still in progress for NCP users

sounds like a bug with the apps themselves, I don’t think it’s related to NCP

The problem with the calendar was fixed with the latest update (2.4.0) of the app.
Only the contacts app still has this issue.