Change ports (80 & 443) in NextCloudPi

Hi everyone!
I am trying to change ports (80 & 443) in light of the inaccessibility of them ( I am running cloud in my house ), and I tried to change:

  • /etc/apache2/ports.conf

  • /etc/apache2/sites-available/default-ssl.conf

  • /etc/apache2/sites-available/000-default.conf

  • /etc/apache2/sites-enabled/001-nextcloud.conf

  • /etc/apache2/sites-enabled/001-nextcloud.conf

  • /var/www/nextcloud/config/config.php

Yet after all of that, the HPB service is always down. Does anyone know how to fully re-port those aforementioned ones?

Maybe you will find the solution there:

The problem is, after changing the port, I cannot alter the way NextCloud tries to setup notify_push (it adresses to localhost, without ports). Nevertheless, I have edited the notify_push.service, by setting nextcloud_url to the correct one. Do you know how to change the nextcloud_url internally?

I have reviewed that solution, I cleared the cache yet it doesnt seem to suit for me.