Certificate not accepted and 503 error

Hello everyone,

I create this topic because I didn’t find any other with the same issues.

So I’m a total newbie to server config and command line use but I followed this very good Tutorial in french to proceed to install NextCloud on my Raspberry Pi 4 B 2Go. Adding an external HDD drive to stock the data.

It worked very well for two months but I stopped on the 31st of march. When trying to access from Firefox I have this error :
HTTP Strict Transport Security : true
HTTP Public Key Pinning : false

And from Brave :
Subject: archlinux
Issuer: archlinux

Expires on: 26 mars 2030
Current date: 6 juin 2020

And when I try to connect directly on my server I get a 503 Service not available error.

I can SSH to the Raspberry and execute commands but when looking from ncp-config point of view everything seems to be fine…

My nextcloud log : https://pastebin.com/2m0qmW8Q

Thanks a lot for your help if possible !

Including a link to it could be useful.

Your dabaseserver is down, try starting it with

sudo systemctl start mariadb.service
or reboot with
sudo shutdown -r now

For the tutorial :

For the first line you gave me I have this :

Warning: The unit file, source configuration file or drop-ins of mariadb.service changed on disk. Run ‘systemctl daemon-reload’ to reload units.
Job for mariadb.service failed because the control process exited with error code.
See “systemctl status mariadb.service” and “journalctl -xe” for details.

Then I executed as recommended : systemctl daemon-reload and I have this response

==== AUTHENTICATING FOR org.freedesktop.systemd1.reload-daemon ===
Authentication is required to reload the systemd state.
Authenticating as: root

I tried to reboot but it doesn’t solve the issue.
From the FAQ you gave me in another topic the database root password should be stored in ncadmin / <random in /root/.my.cnf>. I have to check this later today.

Thanks a lot

The required password was just a question of executing the command as admin. But the daemon-reload didn’t solve the issue even after a restart.

I have these logs for the journalctl -xe / systemctl status mariadb.service and var status from help command :

Still investigating the issue and the fix

I’ve been looking for a while on different websites about the logs I had about the mariadb crash but I wasn’t able to find a solution to my problem.

My understanding of the issue so far :

  • My Raspberry Pi power supply was cut
  • When rebooting the system wasn’t able to restart mariadb

I have these logs : https://pastebin.com/PXU3f6D0

My current solution is to start again from a clean install of NCP using my backup from mid-may but I feel like giving up on the first issue…

Next steps of the issue here