CentOS 7 and CWPpro. WebDAV broken No memory cache has been configured. PHP OPcache is not properly configured

I can not get around this issue I am running on a vServer with
CentOS 7 and CWPpro

I had made a fresh installation yesterday of the CentOS and the CWPpro was installed by support stuff from centos-webpanel.com
so there will not be any issues if i have installed it my self.

I use the account i have created with my CWPpro for to host a domain


this image is when i log in the main page stays on loading all the time
cant upload any thing i do not even have a plus button for creating folders
if i go to gallery and click on plus symbol it looks ok I make attempt to upload
it shows that is uploading but again nothing

this is the error i get

Please Help me I cant take it any longer i think i am going crazy here…

  • Your web server is not yet properly set up to allow file synchronisation, because the WebDAV interface seems to be broken.

  • No memory cache has been configured. To enhance performance, please configure a memcache, if available. Further information can be found in the documentation.

  • The PHP OPcache is not properly configured. For better performance it is recommended to use the following settings in the php.ini :

opcache.enable=1
opcache.enable_cli=1
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.memory_consumption=128
opcache.save_comments=1
opcache.revalidate_freq=1
1 Like

Same here… you ever figure out how to fix it?

I have the same problem does anyone have the solution for this?

Hi,

we run Netxtcloud on a Red Hat 7 Enterprise Server and i have the issues with the opcache.
I have edit the configuration file here and this was the Solution for the opache:

This Package is installed:

php72-php- opcache .x86_64

After the Insatllation you will find a Configuration File here:

/etc/opt/remi/php72/php.d
10-opcache.ini

; Enable Zend OPcache extension module
zend_extension=opcache

; Determines if Zend OPCache is enabled
opcache.enable=1

; Determines if Zend OPCache is enabled for the CLI version of PHP
opcache.enable_cli=1

; The OPcache shared memory storage size.
opcache.memory_consumption=128

; The amount of memory for interned strings in Mbytes.
opcache.interned_strings_buffer=8

; The maximum number of keys (scripts) in the OPcache hash table.
; Only numbers between 200 and 1000000 are allowed.
opcache.max_accelerated_files=10000

opcache.revalidate_freq=60

; Enables or disables file search in include_path optimization
;opcache.revalidate_path=0

; If disabled, all PHPDoc comments are dropped from the code to reduce the

; size of the optimized code.
opcache.save_comments=1

; If enabled, a fast shutdown sequence is used for the accelerated code
; Depending on the used Memory Manager this may cause some incompatibilities.
opcache.fast_shutdown=1

I have php72 from remi repo.

Hi,

for the memcache i have configure this here. In the Nextcloud directory folder conf/config.php

‘memcache.local’ => ‘\OC\Memcache\Memcached’,
‘memcache.distributed’ => ‘\OC\Memcache\Memcached’,
‘memcached_servers’ =>
array (
0 =>
array (
0 => ‘localhost’,
1 => 11211,
),

On the Server i have install this package:

libmemcached.x86_64
memcached.x86_64
php72-php-pecl-memcache.x86_64
php72-php-pecl-memcached.x86_64

You need to install this package first befor you make the configuration in the config.php

https://hanserasmus.wordpress.com/2018/09/02/installing-a-complete-nextcloud-on-centos-7-5-single-instance/ at the bottom of the page you will “Additional Settings” and “OPCache” settings.

1 Like

Working for me:

Step 1:

You can edit httpd.conf (from Apache Configuration in “Apache Settings” in CWP)

Search modules and uncomment the lines (include)

LoadModule alias_module modules/mod_alias.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_user_module modules/mod_authz_core.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dav_lock_module modules/mod_dav_lock.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so

Step 2:

SSH

/usr/local/apache/bin/httpd -M | grep -i dav

Syntax OK
dav_module (static)
dav_fs_module (static)
dav_lock_module (static)

If you show like this, okey go to step 3

Step 3:

Edit

/usr/local/apache/conf/extra/httpd-userdir.conf

Replace with this code:

<Directory "/home/*/public_html"> AllowOverride FileInfo AuthConfig Limit Indexes Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec <Limit GET POST OPTIONS> Order allow,deny Allow from all </Limit> <LimitExcept GET POST OPTIONS> Order deny,allow Deny from all </LimitExcept></Directory>

Step 4: (for Nextcloud/Owncloud and other cloud app)

EDIT

/home/USERNAME/public_html/nextcloud/.htaccess

Add in the bottom of the page

<Limit GET POST> order deny,allow allow from all</Limit><Limit PUT DELETE> order deny,allow allow from all</Limit>

Step 5:

systemctl restart httpd

Hello,

With Fresh install Centos 7 & CWPpro, Apache 7.2, I haved same problem.

For resolution

Rebuild Apache with options

-–enable-dav
-–enable-dav-fs
-–enable-dav-lock
-–enable-auth-digest
-–enable-authn-core
-–enable-authz-core

OK

Uncomment:
LoadModule alias_module modules/mod_alias.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_user_module modules/mod_authz_core.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dav_lock_module modules/mod_dav_lock.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so

Uncomment:
Include conf/extra/httpd-dav.conf

OK

restart
systemctl restart httpd

OK

/usr/local/apache/bin/httpd -M | grep -i dav

dav_module (shared)
dav_fs_module (shared)
dav_lock_module (shared)

OK

Edit
/usr/local/apache/conf/extra/httpd-userdir.conf

Replace with this code:
<Directory “/home/*/public_html”>
AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order deny,allow
Deny from all
</LimitExcept>
</Directory>

OK

systemctl restart httpd

OK

add on .htaccess of nextcloud

<Limit GET POST>
order deny,allow
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
allow from all
</Limit>

OK

Nextcloud is OK

Hi pathoun,
great job.
There is a couple of errors to correct.
By compiling apache with these commands, apache breaks.
replace :
–enable-dav
–enable-dav-fs
–enable-dav-lock
–enable-auth-digest
–enable-authn-core
–enable-authz-core

with this one

-–enable-dav
-–enable-dav-fs
-–enable-dav-lock
-–enable-auth-digest
-–enable-authn-core
-–enable-authz-core

then replace
/usr/local/apache/bin/httpd -M | grep -i dav`
with this
/usr/local/apache/bin/httpd -M | grep -i dav

That’s all

Oops indeed, the formatting had broken my copied pasted … I corrected

Thank you

I will report the problem I had and how I solved it.
After a lot of work I managed to install Nextcloud 19.

Procedures performed:

  1. Rebuild Apache with the following added switches – you can use Apache 2.4.x
    Add…
    –enable-dav
    –enable-dav-fs
    –enable-dav-lock
    –enable-auth-digest
    –enable-authn-core
    –enable-authz-core

  2. Enable the Apache modules: nano /usr/local/apache/conf/httpd.conf

LoadModule alias_module modules/mod_alias.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dav_lock_module modules/mod_dav_lock.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
Include conf/extra/httpd-dav.conf

  1. Restart Apache:
    systemctl restart httpd

  2. Check for dav modules:
    /usr/local/apache/bin/httpd -M | grep -i dav

The result should look like this:

dav_module (shared)
dav_fs_module (shared)
dav_lock_module (shared)

  1. Edit your “httpd-userdir.conf” nano /usr/local/apache/conf/extra/httpd-userdir.conf

…replace everything in this file with the following text…

<Directory “/home/*/public_html”>
AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec

Order allow,deny
Allow from all


Order deny,allow
Deny from all

Edit your Nextcloud .htaccess file
…adding the following data to the end of the file:

order deny,allow allow from all order deny,allow allow from all
  1. The most important.
    For me it only works when I disabled mod security in:
    CWP > Segurity > Flap Accounts > Disable.