Cardbook (in Thunderbird) works for Nextcloud 13, but not 14

thunderbird
nc13
carddav
nc14

#1

I have two Nextcloud servers. One is the current Nextcloud 13 snap, the other is the current Nextcloud 14 snap (14/candidate channel). I can get my Nextcloud Contacts working properly in the Thunderbird (v.60.2.1), with the current Cardbook (v. 33.2), but I can’t get my Nextcloud Contacts from Nextcloud 14 to similarily work.

When I try to Add a new Address Book in Cardbook (from my Nextcloud 14 account), there is an error at the “Validation” (of CardDAV) stage (ie. my URL, username, and password are not wrong):

I guess I’m wondering why it works smoothly in NC13, and no longer “validates” in NC14. I guess a regression was introduced?

BTW: I did an export of all my contacts in NC13 (which Cardbook has no problem with), then imported them straight into my new account on the NC14 server (which Cardbook now has a problem with). I suppose some subtly-bad thing might have been introduced by the export/import process?


#2

Hi there, it is an issue with thunderbird, this post did solve my problem:


This post is in German, i hope u get it.


#3

Thanks for the tip. The workaround doesn’t work for me (first deleting the saved password, then changing the “network.cookie.same-site.enabled” value), however.

Note: I try the DAV URLs of:

https://myserver.com/remote.php/dav/addressbooks/users/myuser/contacts/

…offered by my Nextcloud contacts Settings, as well as:

https://myserver.com/remote.php/dav/addressbooks/users/myuser/Thunderbird/

…which I hand-crafted myself, as there is no “impeller” icon to be seen, as suggested in the Documentation here (look for the red square there).

No luck trying either DAV URL, I get the same “Validation” error messages as before. I’m glad to know the CardDAV developer as well as Thunderbird themselves are well aware of the problem. I think if I just wait long enough, the fix will come down the pipe with a Thunderbird upgrade (I’m in Linux Mint 19.1).


#4

See: https://github.com/nextcloud/server/issues/10134

Try to set network.cookie.same-site.enabled in Thunderbird advanced settings to false.


#5

Yes, I did that, and it still didn’t work.