Can't use all storage, uploads cut to 10MB

:warning: This issue respects the following points: :warning:

Bug description

User unlimited space but cant use it

Expected behavior

to be able to use unlimited space!

Installation method

Community Manual installation with Archive

Nextcloud Server version


Operating system


PHP engine version

PHP 8.2

Web server

Apache (supported)

Database engine version


Is this bug present after an update or on a fresh install?

Fresh Nextcloud Server install

Are you using the Nextcloud Server Encryption module?

Encryption is Disabled

What user-backends are you using?

  • Default user-backend (database)
  • LDAP/ Active Directory
  • SSO - SAML
  • Other

Configuration report

    "system": {
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
        "datadirectory": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "",
        "overwrite.cli.url": "http:\/\/",
        "dbname": "***REMOVED SENSITIVE VALUE***",
        "dbhost": "***REMOVED SENSITIVE VALUE***",
        "dbport": "",
        "dbtableprefix": "oc_",
        "mysql.utf8mb4": true,
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "maintenance_window_start": 1,
        "memcache.local": "\\OC\\Memcache\\Redis",
        "memcache.distributed": "\\OC\\Memcache\\Redis",
        "memcache.locking": "\\OC\\Memcache\\Redis",
        "redis": {
            "host": "***REMOVED SENSITIVE VALUE***",
            "port": 6379
        "default_phone_region": "US",
        "installed": true,
        "maintenance": false,
        "data-fingerprint": "d9406a10eced644733006f377a6be6cf"

List of activated Apps

  - activity: 2.20.0
  - calendar: 4.6.6
  - circles: 28.0.0-dev
  - cloud_federation_api: 1.11.0
  - comments: 1.18.0
  - contacts: 5.5.3
  - contactsinteraction: 1.9.0
  - dashboard: 7.8.0
  - dav: 1.29.1
  - federatedfilesharing: 1.18.0
  - federation: 1.18.0
  - files: 2.0.0
  - files_antivirus: 5.4.2
  - files_external: 1.20.0
  - files_pdfviewer: 2.9.0
  - files_reminders: 1.1.0
  - files_sharing: 1.20.0
  - files_trashbin: 1.18.0
  - files_versions: 1.21.0
  - firstrunwizard: 2.17.0
  - logreader: 2.13.0
  - lookup_server_connector: 1.16.0
  - mail: 3.5.7
  - nextcloud_announcements: 1.17.0
  - notes: 4.9.2
  - notifications: 2.16.0
  - oauth2: 1.16.3
  - password_policy: 1.18.0
  - photos: 2.4.0
  - privacy: 1.12.0
  - provisioning_api: 1.18.0
  - recommendations: 2.0.0
  - related_resources: 1.3.0
  - richdocuments: 8.3.2
  - serverinfo: 1.18.0
  - settings: 1.10.1
  - sharebymail: 1.18.0
  - spreed: 18.0.5
  - support: 1.11.0
  - survey_client: 1.16.0
  - systemtags: 1.18.0
  - text: 3.9.1
  - theming: 2.3.0
  - twofactor_backupcodes: 1.17.0
  - updatenotification: 1.18.0
  - user_status: 1.8.1
  - viewer: 2.2.0
  - weather_status: 1.8.0
  - workflowengine: 2.10.0
  - admin_audit: 1.18.0
  - bruteforcesettings: 2.8.0
  - encryption: 2.16.0
  - suspicious_login: 6.0.0
  - twofactor_totp: 10.0.0-beta.2
  - user_ldap: 1.19.0

Nextcloud Signing status

No errors have been found.

Nextcloud Logs

No errors have been found.

Additional info

I have installed it manually via YouTube videos ! My file directory is in ? /home/nextcloud-data my problem is that my root user is the only one I use he has unlimited space usage but not he wont let me upload anything only small files smaller then 10mb the second user I just created to see if it is just a user issue and the tester user I can upload files fine only not from the admin not his username is kali that’s why I am here it I set to unlimited but I can’t upload large files check the screenshots!

Bildschirmfoto 2024-03-13 um 21 11 23

Bildschirmfoto 2024-03-13 um 21 10 55

Bildschirmfoto 2024-03-13 um 21 13 05

Bildschirmfoto 2024-03-13 um 21 10 07

sometimes strange things happen somehow…

so if this limit only occurs to you admin user you might wanna go checking out how much space this account has enabled… it’s under Users… you can fill in every value you want to the referring field.

I have set admin to unlimited that’s why I wonder it not lets me upload more I just moved 1.6tb files into the directory of that user that’s why I just recognized it so late first when I found that out I were also unable to upload over web nothing then I found out that with user has limited storage! But unlimited were chosen!

Oh now I got what you mentioned I set to 18tb I will test if I can upload now something!

umm 1.6 TB? :scream:

it might take a while for the database to get all the files processed

I have already done the command to reindex ! when I moved the files into the users directory files!

But the problem is still present when I set the users space to 19tb I can’t upload anything over 10mb and on the web gui it says aproxima time to need to upload but it isn’t uploading anything! and is either not showing that it uploads!

But all images that I moved there in the folder I can see without any issue the only issue is uploading and sync files larger then 10mb!

maybe this is of help to you?

They haven’t fixed the issue I tried their method but it wont help also after I run the command I restarted the apache and php but it weren’t helping I also done some research a couple hours but found no solution !

(base) kali@ai-cloud:/$ sudo -u www-data php /var/www/nextcloud/occ config:app:set --value 524288000 files max_chunk_size

Config value max_chunk_size for app files set to 524288000

(base) kali@ai-cloud:/$ sudo systemctl restart apache2 php8.2-fpm redis-server

(base) kali@ai-cloud:/$

I have researched on nextcloud forum GitHub nothing helped and when I started a issue on GitHub they told me to go here that’s why I am here I really don’t know what to do!

The Thing Is i am not getting any error and I tested from several devices!

i am not sure if both problems have the same cause but cron jobs are not done:
sudo crontab -e -u www-data.
I added this line like in the doc:

*/5 * * * * php -f /var/www/nextcloud/cron.php

But nothing happens it appears to me so if I see the nextcloud error:
Last job execution ran an hour ago. Something seems wrong.
first I had ajax but It has told me it weren’t working ajax!

For the cron problem I found a log and a case:
Failed to connect to the database: An exception occurred in the driver: could not find driver

Exception thrown: Doctrine\DBAL\Exception

It looks not like they found a solution!

i have changed also in the nextcloud config ghost from localhost to and restarted nextcloud but it weren’t helping to solve the issue!

One thing I now solved but sync still wont allow me to upload a file that is 10mb or bigger then 10mb!
I had to set my root user that I use to upload files to 2tb and then back to 17tb then I was able to upload files bigger than 10mb but sync still wont let me!

I tried and researched a bit but still no solution I thought might be a client issue but I tried several version and everytime same issue!:

This solved the client issue: Forbidden Sabre\DAV\Exception\Forbidden error - #5 by smamessier

Storage issue solved: I had to set my root user that Is the user I used to upload files, I had to set it to 2tb and then back to 17tb then I was able to upload files bigger than 10mb!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.