Can't upload or create files after web installation

Hi all,

I just installed nextcloud on a webspace I rented via the web installer and the setup went smoothly.
Now I’m having the Problem that nextcloud doesn’t seem to be able to write any changes in different situations. Here’s what I noticed:

I can’t create any files or upload them, I only get a “Unknown Error occurred” or “Could not create file” message, but I can create directories. Furthermore, I cannot change my display name in the settings, but I can create a new user, and nextcloud will write all of the new users default files into the data directory upon first login, it is also possible to change a user’s password. Another interesting thing is, that I always get that “welcome” screen you see on an accounts first login every time I go to the files view.

I already tried reinstalling it, and I also tried using the premade nextcloud installer provided by my webspace provider, but I always get the same problem.

Here is some Information about the setup:

Nextcloud version:
php version: 7.2.19
database: MariaDB 10.2.22
The webspace seems to be using apache 4.5.2
and the server seems also to be running ubuntu, but as it is only a webspace I rented, I won’t be able to make many adjustments in that area.

The nextcloud log does not mention anything interesting (only one entry about a password being too short)

This is my config.php:

<?php $CONFIG = array ( 'instanceid' => 'ociclb1s2zeq', 'passwordsalt' => '****', 'secret' => '<secret, I guess>', 'trusted_domains' => array ( 0 => '<doman>', ), 'datadirectory' => '/<a path>/web/nextcloud/data', 'dbtype' => 'mysql', 'version' => '', 'overwrite.cli.url' => 'https://<domain>/nextcloud', 'dbname' => '<dbname>', 'dbhost' => '<db's host>', 'dbport' => '', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => '*****', 'dbpassword' => '*****', 'installed' => true, );

I am grateful for any help I can get!