Can't upload large files. Error when assembling chunks. status code 504(Nextcloud 19.0.0)

I have been researching this issue for weeks without finding a solution. I orginally had the nextcloud instance installed as a snap. It was on its own Ubuntu 18.04(up to date) server, behind an nginx reverse proxy. The way the nextcloud server was configured was the data folder was stores on an nfs file share mounted to the ubuntu server. I wanted to change this and try to eliminate unnecessary variables. So I build a completely fresh ubuntu VM(20.04), installed nextcloud following this article, and tested uploading the same 2.5GB file with the same result. I though it must be the reverse proxy causing the issue, so I navigated to the local IP of the nextcloud server and tried that way and got the same error. I have read a ton of articles describing this or similar issues and have gone through all my settings trying to tweak and change to get rid of this error. Please let me know what info you need. Thank you.

2 Likes

this is bug 100% i dont know why devs not fix it, I always get this error, but files load normally. someday developers will fix it

1 Like

Have you tried searching this forum?

It’s a timing issue… The file is split in chunks, uploaded and reassembled…
If the hardware is slow/weak/old, it times out… Change the timeout variable and it will stop happening…

Ya, like I said, I have done a lot of research and changed/tweaked a ton of settings, I tried changing all the timeout settings(nginx reverse proxy, apache, phpfpm, nextcloud config).

You did? Going by the content of your two posts you came here to rant…

Also having the 504 (gateway timeout) issue with large file uploads.

Increasing the timeouts solved it for me. I wrote about that here: