Can't upload files more than 500 mb

Nextcloud version : 23.0.4
Operating system and version (eg, Ubuntu 20.04): TrueNAS CORE

I can’t upload files (video for example) of more than 500 Mb on my private nextcloud server. It is insatalled on a TrueNAS core server.

I tried changing the settings in the .ini and .php files etc (spent a good 3h) to find the parameters :

upload_max_filesize = 
post_max_size =

But in vain.

I have access to the TrueNAS shell, and the nextcloud jail’s shell :

But I can’t find the configuration files where I can change the upload and post max file sizes.

Also, logging in as admin, there is not “additional settings” in the nextcloud GUI where I can change the file size limitation.

(as in I don’t have this tab :slight_smile:

Thanks for any help


upload_max_filesize = 10240M
memory_limit = 512M

see also /etc/nginx/conf.d/nextcloud.conf, if you run a nginx - you have to google for apache config

# set max upload size
client_max_body_size 10240M;

Hi, thanks, but there’s no php folder in my /etc folder.
neither on the global shell :
no /nginx here either

nor the nextcloud jail’s shell :
no /nginx here either again.

hey I’d really love to solve this problem, if anyone knows a solution i’d really appreciate.

up please it would be appreciated

Actually I found the nginx folder and the file.

thanks to the vi editor helpdoc i could modify the line client_max_body_size from ‘512M’ to ‘16G’ and save it, then restart the whole nextcloud jail.