"Can't update non existing placeholder info" error

So I added a folder sync connect to sync a large folder to my nextcloud overnight. But I’m left with a few errors for the largest files that I can’t seem to dismiss: “Can’t upload non existing placeholder info”. What does this mean? The files show up in Nextcloud web app, but the sync error won’t go away even after restarting Nextcloud.

1 Like

So I removed and re-added the sync connection, and after a while of checking everything, status is OK. Still, I would like to understand what went wrong

1 Like

Got the message too. From one moment to the next. Client also freezes and then no longer synced for a very long time.

Very frustrating, all the error messages over the last few months in the Nextcloud client.

When I keep files in sync with a client, I have to trust the program not to destroy the files or lose files in the sync. The amount of problems is already testing the trust in the client.

So that it does not become boring directly a new error message.
“Could not make fd from hande”

Upon adding a folder to sync in Windows 11 a few files gave this error also:

can’t update non existing placeholder info

The files were uploaded, so in effect nothing seems wrong, only the error itself!?

I could resolve the error in a crummy way:

  1. delete the files locally
  2. force a sync => all is well
  3. restore the files from windows trash
  4. force a sync => all is well, including the loss of the faulty(?) error

We are also facing this issue. Removing files, force scanning and re-adding it did not fix the issue.

Got the same here… (Win10 client) with multiple files! Any sync they will pop up as error. However I have found that it is only about small files with 1-2KB. Other files perform well. But any file below ~5kB runs into that error.

No further idea here.

I also have the same error messages, mostly are the size bigger the 1gb file. I tried move the files that has occurred error outside of sync folder > sync > move back to sync folder, error insisted

Things got weird, even though has error message for that file,
can’t update non existing placeholder info
The nextcloud server drive has the file with same name and file size, what I worry about is the file one the server has corrupted or missing some information due the error has occurred on this file

Update 2022/9/20
Right now I’am able to sync file larger >1Gb by move the big file one by one to the sync folder
But so sorry for other people I forgot what configuration has changed.

  1. 504 gateway timeout cause the files not sync completely.
    --------- How to Fix 504 Gateway Timeout using Nginx – Easy Cloud (zendesk.com)
  2. Nginx Proxy, PHP-FPM timeout value may need higher
  3. Move all the files out of the sync folder that has errors, after no errors in desktop sync app, move the file into sync folder one by one.


i having this error as well.

When i moved a folder inside a shared folder, some files could not get synced and got this error.
I had to get these files from a backup because some of the files were missing.

Windows 10 22H2, Nextcloud Client 3.6.4, and Nextcloud server 25.0.2 on a jail in TrueNAS

1 Like

So… the same thing happened to me, for both Windows and Linux appImage clients.
Tried with no luck:

occ files:scan
occ preview:generate-all
occ preview:pre-generate

But… simple

  • delete failing folder using webUI
  • scync on windows client
  • restore folder using webUI
  • scync again on windows client
  • SUCCESS, error is gone.

What I havn’t tried was

occ preview:repair

since it looks like exhausting/overkill operation as for 4 files while I have like ~10K of them.

A simple workaround for me is:

  • Rename the parent folder with the files throwing the error to another name in the Nextcloud WebUI
  • Wait for Resync of the client (or do a force resync)
  • Rename the folder back to the old name
  • Resync again

Error is gone for me in this case.

1 Like

Same error here.
Looking forward to a client update, thanks a lot for corwin workaround, it works like a charm!

When I try to upload lnk files, an error occurs for all uploaded upstream folders:

Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\Admin\\99. Tools\\02. Disk\\h2testw.exe"
Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\Admin\\99. Tools\\02. Disk\\Scanner.exe"
Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\Admin\\99. Tools\\03. DataBases"
Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\Admin\\99. Tools\\SYNC.lnk"
Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\Admin\\icons\\TeamViewer.ico"
Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\Admin\\icons\\tvnviewer.ico"
Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\Admin\\QuickLinks.ahk"
Couldn't find pin state for regular non-placeholder file "C:\\NextCloud\\work\\Ammy\\rdp.exe"

But really problem only in lnk files.
When I do a file-by-file upload, there is no problem until I get to lnk.
If I unload even one lnk, then the client frezeed and a timeout connection error appears for all accounts.
Check for link files and remove them from upload