Can't update from ncp 1.20.0 -> 1.20.1

Nextcloud version 17.0.2.1:
Operating system and version Debian 9 (NextcloudPi 1.20.0:

The issue you are facing:
I can’t update to a new NCP version via ncp-update, the web panel or ncp-config it always says:

Downloading updates
Performing updates
Update to buster available. Type 'sudo ncp-dist-upgrade' to upgrade
Unknown user

But then I’m still on 1.20.0 this never happens before all other updates before this one worked out of the box.

Steps to replicate it:

  1. SSH into your cloud write sudo ncp-update
  2. View the “update” progress
  3. Be still on the old version.

Here is my output of ncp-report: https://gist.github.com/crowbarcode/fbd89eef47b93eef86fc4d6b81d79978

Hopefully someone has the solution!

Is the most probable solution, make backups before you start tho, just in case… better safe than sorry :wink:
Afaik most ncp users have moved to Buster (Debian 10), without major issues.

@OliverV Well do you think this is the reason? Any other suggestions?

Did you manage to fix the problem ? I’m also stucked on 1.20.0