Can't update apps

Hi,

I have the same problem too.

calendar new version available: 3.0.6
calendar couldn’t be updated
contacts new version available: 4.0.8
contacts couldn’t be updated
richdocuments new version available: 5.0.2
richdocuments couldn’t be updated

any help appreciated…thank you

apparently not. So we’d need more info about your instance(s), environment and installed apps/software

I am running on

Operating System:Linux 5.10.60.1-microsoft-standard-WSL2 x86_64
PHP Version : Version: 8.0.16
MySql version: 10.3.32
Nextcloud : 23.0.2

Every time I tried to update the apps…error shows

GuzzleHttp\Exception\ConnectException: cURL error 28: Operation timed out after 150000 milliseconds with 0 out of 0 bytes received (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://github.com/nextcloud-releases/contacts/releases/download/v4.0.8/contacts-v4.0.8.tar.gz

I’ve been pulling out my hair trying to fix this problem…but no luck.

r u sure that there’s no built-in firewall blocking your system?

I never tried to run NC on a windows built-in linux… I do remember that there were several problems with that kind of setup at times.

Maybe a VM would be better?

I’m not entirely sure whether it’s the built-in firewall from ubuntu or the firewall from wsl2/windows that causing the problem.
I just find it strange, cause I was able to upgrade the nextcloud from version 23.0.0 to 23.0.2 without any issue.

:~$ sudo ufw status verbose
Status: active
Logging: off
Default: allow (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To Action From


127.0.0.1 3310/tcp ALLOW IN 127.0.0.1
80/tcp ALLOW IN Anywhere
Anywhere ALLOW IN 127.0.0.1
443/tcp ALLOW IN Anywhere
3310/tcp ALLOW IN Anywhere
22/tcp ALLOW IN Anywhere
80/tcp (v6) ALLOW IN Anywhere (v6)
443/tcp (v6) ALLOW IN Anywhere (v6)
3310/tcp (v6) ALLOW IN Anywhere (v6)
22/tcp (v6) ALLOW IN Anywhere (v6)

I have also tried opening the port at the powershell with this command
netsh advfirewall firewall add rule name= “Open Port 80” dir=in action=allow protocol=TCP localport=80
and
New-NetFirewallRule -DisplayName “WSL” -Direction Inbound -InterfaceAlias “vEthernet (WSL)” -Action Allow

Name : {ff1b9e6b-7ee6-4d41-b612-55ec65cb24ca}
DisplayName : WSL
Description :
DisplayGroup :
Group :
Enabled : True
Profile : Any
Platform : {}
Direction : Inbound
Action : Allow
EdgeTraversalPolicy : Block
LooseSourceMapping : False
LocalOnlyMapping : False
Owner :
PrimaryStatus : OK
Status : The rule was parsed successfully from the store. (65536)
EnforcementStatus : NotApplicable
PolicyStoreSource : PersistentStore
PolicyStoreSourceType : Local

But still can’t update the apps…

Uninstall ufw on your system. You do not need it.

I have tried the command “sudo ufw disable”…reboot the server…still can’t update …perhaps do you mean remove the ufw totally?
like sudo apt-get remove ufw or sudo apt-get purge ufw?

If it is really disabled i think it is fine and you must not uninstall it.

Can you test a direct download on the server e.g.

curl https://github.com/nextcloud-releases/contacts/releases/download/v4.0.8/contacts-v4.0.8.tar.gz

wget https://github.com/nextcloud-releases/contacts/releases/download/v4.0.8/contacts-v4.0.8.tar.gz

You can download in a tmp dir e.g. /tmp. Please post errors.

I am getting the below;

curl: (35) OpenSSL SSL_connect: Connection reset by peer in connection to github.com:443

and

–2022-02-23 22:48:43-- https://github.com/nextcloud-releases/contacts/releases/download/v4.0.8/contacts-v4.0.8.tar.gz
Resolving github.com (github.com)… 20.205.243.166
Connecting to github.com (github.com)|20.205.243.166|:443… connected.

Any ideas how to fix this?