Can't see files in browser

Hi all!
I’m running NextcloudPi on Raspberry Pi 2 from a few weeks and it works quite fine.

But I’m facing a relatively surprising problem: can’t see files and folders in the browser.
Tried on 2 different computers (similar Xubuntu 16.04 and firefox ), but nothing shows. Everything exists because I can see every file and folder from the mobile app, automatic upload from phone works, calendar and contacts show in the browser and sync to phone/Thunderbird is OK. Just the files don’t show in browser…

Haven’t tried with the desktop app yet, but should work (not really interested to use desktop app).

Was self hosting ownCloud before even Nextcloud existed, moved to Nextcloud, moved to NextcloudPi for ease of use: have some experience of problems, but nothing like this.

So I already want to thank you for your ideas/interrest and time taken.

When you say the files don’t show, do you mean like you have a web user interface but no files, or it’s a completely white screen?

I have all the web interface, I can navigate to contacts or calendar which show flawlessly but when I navigate back to “Files” no files and no folder.

Hmmmm double check to make sure permissions are properly set in your “apps” folder in your nextclouddir, also make sure it’s pointing to the proper data directory in your config.php file

Hi, thank’s for the ideas.

config.php looks good.

For the permissions, I have this in /var/www/nextcloud/apps/files:
drwxr-x— 2 www-data www-data 4096 Jul 23 10:48 ajax
drwxr-x— 2 www-data www-data 4096 Jul 23 10:52 appinfo
drwxr-x— 3 www-data www-data 4096 Jul 23 10:48 composer
drwxr-x— 2 www-data www-data 4096 Jul 23 10:48 css
-rw-r----- 1 www-data www-data 1718 Jul 23 10:48 download.php
drwxr-x— 2 www-data www-data 4096 Jul 23 10:48 img
drwxr-x— 3 www-data www-data 4096 Jul 23 10:48 js
drwxr-x— 2 www-data www-data 12288 Jul 23 10:48 l10n
drwxr-x— 9 www-data www-data 4096 Jul 23 10:48 lib
-rw-r----- 1 www-data www-data 1157 Jul 23 10:48 list.php
-rw-r----- 1 www-data www-data 966 Jul 23 10:48 recentlist.php
-rw-r----- 1 www-data www-data 956 Jul 23 10:48 simplelist.php
drwxr-x— 2 www-data www-data 4096 Jul 23 10:48 templates

Does it seem to be ok to you?

To add, I noticed that I have no full web interface, home button and the + button are missing.

For example see:

In comparaison to that image, I have all the left pannel and the top blue pannel, but the central pannel is totally blank, no buttons or head of columns…

Hey sorry for the late reply, to this. Make sure your permissions are properly applied to all of /var/www/nextcloud as well as whatevr your data directory is


What are the proper permissions for /nextcloud files and directories?



I’m facing a similar Problem. I can see the top and the left pannels while the central one is just white. Have you solved it yet?

I have the same problem. It works great in Chrome, but not in Safari (on Mac OS) and Firefox (Windows).

Here a screenshot from Chrome:

And here from Firefox:

What I see now that the URL is not the same, but if I use in Firefox the same URL like in Chrome, it’s the same result as shown in the screenshot (

Version of Nextcloud: 18.0.4

Thanks for the information mate. I tried on Chrome (usually use Firefox) and still have the same problem, my information’s gone…


I had exactly the same issue after latest update (nextcloud 21.0.5), Files app was not displayed using any browser (but files still there and available with mobile applications).

To solve that issue :

  1. By CLI on my nextcloud server :
    sudo -u www-data php /var/www/nextcloud/occ maintenance:repair
  2. Reboot
  3. Clear cache on my browser
  4. Files are now displayed.

Hi, I have the same issue with a nextcloud instance (ubuntu/snap-app) and using Firefox Browser. I just solved it and wanted to add a subtle detail here.

I noticed, that accessing the Web-Interface from within a Firefox-Private-Window/-Tab works fine, but from within a normal Tab it won’t. This is a bit easier to check.

What finally repaired the issue for me, was clearing the Cookies, Site-Data and Cached Web-Content of the Browser ( Now normal Tabs work fine too.

Maybe this is just a client-side (browser) problem… Or somehow cache-invalidation of the web-app fails under certain circumstances. Or whatever XD