Can't save selection of Cron Job in background jobs

Nextcloud version (eg, 20.0.5): STABLE CHANNEL
Operating system and version (eg, Ubuntu 20.04): Linux 4.18.0-348.7.1.el8_5.x86_64 x86_64
Apache or nginx version (eg, Apache 2.4.25): LITESPEED/1.7.15
PHP version (eg, 7.4): 8.0.17

The issue you are facing:

I go to background jobs and select cron instead of ajax that is selected by default.But my selection doesn’t save. All the others settings i change are saved normally.

It is a fresh install , new build server clear os ,running cyperpanel.

Is this the first time you’ve seen this error? (Y/N):Yes

Steps to replicate it:

  1. Go to settings.
  2. Administration
  3. Basic Settings
  4. Select Cron from Background Jobs

The output of your Nextcloud log in Admin > Logging:

No error logs

Maybe this will help you as an alternative.

php ./occ background:cron

Use the background command to select which scheduler you want to use for controlling background jobs, Ajax, Webcron, or Cron. This is the same as using the Cron section on your Nextcloud Admin page

– Quote: Nextcloud Documentation

1 Like

Thank’s for the help.

This solve my problem,cron job is working now.