Can't renew Let's encrypt

I tried, but diesen’t work:
/var/www/html/apps/gallery/js/vendor# sudo certbot certonly --apache -n -d

Traceback (most recent call last):
File “/usr/bin/certbot”, line 11, in
load_entry_point(‘certbot==0.28.0’, ‘console_scripts’, ‘certbot’)()
File “/usr/lib/python3/dist-packages/pkg_resources/”, line 561, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File “/usr/lib/python3/dist-packages/pkg_resources/”, line 2631, in load_entry_point
return ep.load()
File “/usr/lib/python3/dist-packages/pkg_resources/”, line 2291, in load
return self.resolve()
File “/usr/lib/python3/dist-packages/pkg_resources/”, line 2297, in resolve
module = import(self.module_name, fromlist=[‘name’], level=0)
File “/usr/lib/python3/dist-packages/certbot/”, line 19, in
from certbot import cert_manager
File “/usr/lib/python3/dist-packages/certbot/”, line 16, in
from certbot import storage
File “/usr/lib/python3/dist-packages/certbot/”, line 16, in
from certbot import cli
File “/usr/lib/python3/dist-packages/certbot/”, line 36, in
import certbot.plugins.selection as plugin_selection
File “”, line 983, in _find_and_load
File “”, line 967, in _find_and_load_unlocked
File “”, line 677, in _load_unlocked
File “”, line 724, in exec_module
File “”, line 857, in get_code
File “”, line 525, in _compile_bytecode
ValueError: bad marshal data (unknown type code)

I have no idea what is wrong with my installation

ist this an answer?

edit: wrong paste

I’m not really sure it is the right solution. But I find out, that I have 4 different python folders at /user/lib. python2.7, python3, python3.5, python3.7

python -V 
Python 2.7.16

You can try

instead of certbot. --renew -d --force --issue --apache -d

I did
apt-get install acme --renew -d --force command not found

I believe you have an error there. Try as described in Docu:

curl | sh

Or like this:

git clone
./ --install  \
--home ~/myacme \
--config-home ~/myacme/data \
--cert-home  ~/mycerts \
--accountemail  "" \
--accountkey  ~/myaccount.key \
--accountconf ~/myaccount.conf \
--useragent  "this is my client."

curl | sh

[Do Aug 15 15:37:34 CEST 2019] Install success! --renew -d --force command not found

According to this ticket, please check it here: /root/ In any way during the installation process it should give you a hint where it was copied.

but there is an other Problem: is not a issued domain

No ideal what’s wrong with my system?

Is that an error message you’re receiving? If so, there should be more context, and it’d be very helpful if you’d provide it. Or are you saying that you’re using a domain you don’t actually own? If that’s the case, you shouldn’t have been able to get a cert from Let’s Encrypt in the first place.

Yes, it is an error message I receive when using --renew -d --force

I always get a certificate in the past with
/var/www/html/apps/gallery/js/vendor# sudo certbot certonly --apache -n -d

But it ends in an error, too.
The domain is a DynDNS-address:

So you’re telling to renew a domain it hasn’t issued before? Why do you think that will work?

1 Like

There are 2 ways that you can go:

  1. Issue new Certificate with acme.
  • Stop apache2
sudo service apache2 stop
  • issue new certificate
sudo --issue --alpn -d
  • Check that path to the new certificate is configured in your apache2 config.
  • Start the Apache2 server:
sudo service apache2 start
  1. Renew with certbot with debugging:
    I see that you run renew with python 3 (at least from errors), but your default is python 2.7. I believe that certbot is trying to be executed with python 2.7. Seems also an old ticket regarding python version:

Sorry for the late reply, but I’m not sure I understand what you’re trying to do.
The command to renew a Let’s Encrypt certificate is “certbot renew”. The command you tried would have created a new certificate.

Yes, but there are at least 2 tools exist (in this tread): Acme and Certbot. If Tool A of them does not work anymore, then try to take tool B.
You can move issued certificate by your hand between tools A and B, but it will be more efficient way to do it is to issue Certificate again with a working tool B. After that you have to renew it only.