Can't remove contacts from contact groups?

Hi all - had a look and can’t see the exact issue I have so posting to see if anyone else has had this.

If I am editing a contact and try to remove the contact’s membership of a contact group (say they are mistakenly in the wrong group) it looks to have worked after clicking the ‘x’ in top corner of the group entry in the groups field. But after clicking save and exiting the edit screen the contact group has not been removed after all. Have tried with various contacts and groups and get the same result, so not an issue with any specific contact or group. Can’t see any other way of doing it so has anyone else a light to shine?

NC 27.1.5 with Contacts App 5.5.0
Ubuntu Server - all up to date
PHP 8.1
Nginx 1.18.0

Everything else working fine as far as I can tell :grinning:

OK - have found a workaround - if I delete all contact groups from a contact’s details and then re-add the one(s) I do want, it works. However, simply deleting one of several from the list does not work and the group is still there after saving.