Can't remove account from the desktop client GUI

Hi all,
A few days ago my NC desktop client got updated to v3.4.0.
I run the client on the latest Kubuntu LTS.

Since then I can’t left-click the systemtray icon to get the user manager etc. Nothing happens.
Ie I can’t get the former gui, as seen on GitHub - nextcloud/desktop: 💻 Desktop sync client for Nextcloud at the bottom of the page.

Right-clicking works, and shows me Add account, Pause sync, Settings and Exit Nextcloud.

Clicking settings shows me the regular folder view:

image

Choosing the account I want to remove, I have nowhere to choose to remove the account:

Do I miss some dependency or something?
What’s happening?

Please advise!

On my mac I click on the tray icon.
Then I right click on the three dot next to my profile and there is “Remove account”.

Checked with v3.4.0 like yours.

I have those three dots on one of the accounts, but not on the account I’m trying to remove.
While I do have the tree dots on my other account, there is no Remove account-choice, only Remove folder sync connection.

You can see the three dots are missing on the last pic in my original post.

Also, I’ve tried purged the installationen of the desktop client, and then reinstalled.
No change. Remove account is still missing.

No, I do not talk about the settings windows incl. sync jobs.

I talk about the window which is coming up by clicking the tray icon with a single left click.

Please see

Bildschirmfoto 2021-12-03 um 14.24.05

Aha, okay. Yeah, that’s the popup I can’t seem to get when I left-click on the systemtray icon.
I had it before.

So, this is solved for you now?

No. I still don’t see the view you screendumped.
Also, my other account that worked yesterday is now for some reason signed out and inaccessible.

The web gui still works fine, it’s just the desktop client that’s giving me grief currently.

I’ll uninstalling the client, purging the settings and try out the snap instead.
Maybe it’ll work better.

Just installed the AppImage from the official repo nextcloud.com, after purging the install and removing the repo.
I now have a completely different-looking desktop client, the left-click works and also have an update-button under the General settings.

I also have a slightly older desktop client.
This is v3.3.6 while my previous was 3.4.0.

So far, I’m tentatively optimistic about the function! :slight_smile:

1 Like